• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^

No heats from VENTS and FLOOR!

jaredlangston

Member
Joined
July 27, 2004
Messages
40
Reaction score
0
City, State
Columbus, Oh
Year, Model & Trim Level
99 limited
No heat from VENTS and FLOOR!

Here's what's going on. I have a 99 explorer limited sohc 4.0. This has all the electric heat and a/c contols.

My problem is that I only get heat or a/c from the defrosters. No matter what setting I have it set to.

My a/c only kinda works never blows really cold air.

Also my heat has to be on the hottest setting 90 degrees to even blow heat out. Same thing with A/C only on the coldest setting. The heat gets very hot. But its either that or no heat.

No problems with overheating.

Rear vents work and rear defrosters work.

When either the heat or the a/c is on I hear a clicking sound from under the driver side of the hood. The clicking sound is about every 15 seconds. When I turn the heat off it immediately goes away.

I have looked up stuff hear and saw that it is probably the blend door. I think I can do the "nail trick". It could also be a vacuum problem. I have no idea where to look for that. But it seems like there is more to it than just that. Any photos or links would be great!

Any Ideas?

Thanks Everyone

Jared
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.












zhanx

Explorer Addict
Joined
April 6, 2004
Messages
1,454
Reaction score
4
City, State
Up state NY
Year, Model & Trim Level
2000 xls
also check the vacuum ball under the hood. it a line comes loose it will does the same mine did.
 








ackeblack

New Member
Joined
November 26, 2004
Messages
4
Reaction score
0
City, State
Ludvika,Dalarna
Year, Model & Trim Level
97 explorer
Blend door

Yeah, done that on my 97 explorer today but i cut open the bottom of the "heatbox" and managed to glue together the original parts of the door and put it back in place...
The upper section/hinge of the door had cracked into two pieces, i glued them and then made a small cut around it in two places and reinforced with some metal- worked like a charm and now i got cold and warm in full function again... It´s nice too have a warm car here in Sweden during the winter but full heat all the time is a little too much...driving with the windows down make people look a little funny at u..
 




Top