• Register Today It's free! This box and some ads will disappear once registered!

No Start or Crank, also random door ajar and info center reset


MyExplorer03v8Lim

Active Member
Joined
June 20, 2016
Messages
257
Reaction score
14
Year, Model & Trim Level
2003 Explorer 4.6L
Hello explorers

2003 v8 Limited AWD

For a while now, I've had two issues going on.

First, occasionally when I turn the key, nothing happens for a few seconds and then she fires right up. I've thought this could be 1. Bad starter 2. Bad ground somewhere 3. Bad ignition switch

Second, randomly, or sometimes when it's cold outside, I get the door ajar issue which could either be a stuck latch or a broken wire in the rubber boot at the hinge area.

YESTERDAY

I had the door ajar issue when I started it, but it started right up.

Then I drove for 30 min, parked, and when I came out to start the car... nothing. I tried the key dozens of times ... While articulating the door, the shift knob, jiggling and angling the key in the ignition, all to no avail.

There is one other weird thing. The information center is displaying dashes where data for mpg, mileage etc was. And when I turn the key, the mileage will intermittently appear and the revert back to dashes.

Any thoughts?
 




MyExplorer03v8Lim

Active Member
Joined
June 20, 2016
Messages
257
Reaction score
14
Year, Model & Trim Level
2003 Explorer 4.6L
Does anyone have anything to add on this?
 




Guy Schaefer

New Member
Joined
October 4, 2018
Messages
3
Reaction score
1
City, State
Westminster
Year, Model & Trim Level
2002 Explorer XLT 4WD
May not be your issue but worth telling:

I chased a no start no crank for a week after installing an aftermarket radio. Turns out I bumped the gear lever while installing so the vehicle didn't think it was in park.

Make sure your Digital Transmission Range sensor is adjusted properly!
 




Top