No start without jump 2017 limited | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

No start without jump 2017 limited

icecoldbear62

Member
Joined
May 1, 2013
Messages
19
Reaction score
1
City, State
massachusetts
Year, Model & Trim Level
04 Mercury Mountaineer Pr
I have a 2017 Explorer limited and since the weather got cold my battery is dead every morning bu starts up fine with a jump !!
I know what your thinking and yes I went out and got a new battery I even paid the extra and bought the Optima red top with exact fit and two days later go out to head to work no start use wife’s car to jump it fired right up fine all day anyone have any ideas took it to Empire Ford in New Bedford they wanted to sell me a battery when I told them if it’s the battery I’ll just go to place I got it and get it replaced !!!!
THEN THEY TRIED TO CHARGE ME 90.00 FOR A BATTERY CHECK WHEN I TOLD THEM FALL RIVER FOR SAID THEY WOULD CHECK IT FREE THEN IT WAS 30.00 NOW I JUST BOUGHT THIS TRUCK FROM EMPIRE FORD 3 WEEKS EARLIER THEY SAID THAT ITS NOT POSSIBLE TO BE HAVING THIS PROBLEM THEY DO A VERY EXTENSIVE CHECK ON ALL THERE USED CARS THEN I TOLD THEM I BOUGHT THE EXTENDED WARRANTY they still gave me crap it’s been back there 5 times in a month and all I get is it started up for us !!!
 






Did you have the charging system checked to eliminate the alternator and charging circuit?

Do you have a multi-meter? If you check voltage at the battery with the car off, it should be around 12-13 volts with a fresh battery. When the car is running you should get 14.5-15 volts as the alternator will be ‘charging’.
 






I have read where some auto parts stores will do a free battery check. As for the Ford ESP, it doesn't cover batteries. It sounds like you may have something that is draining your battery when it sits overnight. I attempted to do a Forum 'Search' for a similar problem but there seems to be an issue with the servers at this time.

Peter
 






Back
Top