o/d light flashing..'check transmission' | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

o/d light flashing..'check transmission'

jlgray81

Member
Joined
January 10, 2014
Messages
37
Reaction score
0
City, State
Columbia, Tn
Year, Model & Trim Level
2002 EB Explorer
As I was driving home tonight, I had the trailer attached with no load. I was coming up a hill which I come up everyday on my way home. I felt a kick in the tranny. Afterwards the chime when off and I looked down at the cluster and the center said 'check transmission' and the o/d light was flashing. After about 1 minute it went away. Just had the tranny serviced with a fluid change about 3 weeks ago and they said the fluid looked great and there were no shavings. Can anyone help me out here. Maybe someone has had this issue. Any help or info would be grateful
 






The computer saw a problem in the trans, perhaps it slipped. Best advice is don't tow in OD except on level ground or down hill. Run it and see if the problem comes back. A code may have been stored in the computer, you could get it read.
 






The computer saw a problem in the trans, perhaps it slipped. Best advice is don't tow in OD except on level ground or down hill. Run it and see if the problem comes back. A code may have been stored in the computer, you could get it read.

Thanks for the reply, Pop. I wasn't in OD. Previously, I'd been having a small shift flare between 4th and 5th/OD, so beings I drive in the city 95% of the time I decided to just keep it out of OD. I've not been having problems since then until lastnight. I don't know a lot about these vehicles but I do know that this is a POS tranny from what I've read. 5r55w. I can't get the code read until about Wednesday or Thursday. I'm hoping that whatever code it has thrown will be the fix to the current problem along with the 4th-5th/OD flare. Is that possible? I have read that valve bodys are a huge problems with the W.

A question I have for you, an anyone else is...Opinion based...Lets say its the valve body, would you get a used, reman, or new VB? I know on a used unit, it would be a chance you are purchasing another persons problem. In either selection, would you get one with a new solenoid pack or choose to get one without? I'm just looking at it like this..If I have the VB off, is it gonna hurt to change out the solenoid pack? Just to keep from having to MAYBE do it in the future or should I just roll the dice and only fix the current problem? I know its just an opinion, but I'd like to see what others would do. Thanks!
 






Back
Top