Solved - Odometer stopped working | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Solved Odometer stopped working

Prefix for threads that contain problems that have been resolved, and there is an answer within the thread.

TCrider

New Member
Joined
September 6, 2020
Messages
3
Reaction score
1
City, State
Austin
Year, Model & Trim Level
1996 Explorer XLT V8 5.0L
Okay so I have a 96 XLT and the odometer has stopped working. Occasionally it starts up again for about 5 miles then stops again. The Speedometer is works as it always has. That probably means the VSS and back circuit board is fine, right?

Every thread I've seen says the problem should point toward the worm gear in the odometer, that the rubbery plastic is junk and breaks and needs replacing. I pulled it all apart and saw the worm gear and i looks fine. Definitely not like other's photos show. The only other source of failure would be the motor that spins the worm gear.

Does my worm look like it needs to be replaced? Or could it be the motor, if so how can i test the odometer motor?
 

Attachments

  • worm gear 1.jpg
    worm gear 1.jpg
    50.7 KB · Views: 176



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





Worm gear looks good from here. Isn’t there a plastic gear on the odometer side? How does it look?

Good luck.
 






Worm gear looks good from here. Isn’t there a plastic gear on the odometer side? How does it look?

Good luck.

Yea there is but look great and when i removed the motor the inner gears turned effortlessly with a lock pick turning them.
 






Looks like you need a replacement unit from salvage/junkyard. You will probably get the entire Instrument cluster, but can save the other parts for future. Swap parts as needed. If your speedometer works, the problem should be right there.

Good luck.
 






So I went to a salvage yard and got a motor from a newer model and ordered a new worm gear. That seemed to fix it. Thanks to all the advice.
 






Well done!!!
 






So I went to a salvage yard and got a motor from a newer model and ordered a new worm gear. That seemed to fix it. Thanks to all the advice.
Where did you get the worm gear? I have a 2001 sport trac and the odometer quit working and the Ford Dealerships don't sell replacements so what am I looking for from after market as no one lists my truck. I do not want to use a salvage worm gear and have the same problem or worse yet buy one that is already broken. TIA
 






Hi guys, I know there are about a million 'my odometer stopped working threads' out there, so I thought I would bring back one of the more recent ones instead of posting new.

I've got the same problem as the OP, odometer sometimes works, sometimes doesn't. Has been going on for a couple thousand miles now. 1997 Mountaineer. Following up to see if this repair stuck or there is something else to look for (OP wound up replacing the odo drive motor).

Again, I am a little stumped because of the intermittent nature of the issue. Leads me to believe the gear is OK and something else is going on.

Thanks, Andrew
 






Back
Top