• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^

Oil pump problem

fubarman

Elite Explorer
Joined
July 11, 2009
Messages
4
Reaction score
0
City, State
Pullman WA
Year, Model & Trim Level
1996 Eddie Bauer
I am helping a friend he has a 94 explorer that has been sitting for a couple years. Tha cat was plugged so I replaced it with one that has been cleaned out. Took the explorer for a drive runs great now but oil pressure gage started dropping to nothing. Lifters had already been ticking. I change sending unit started engine good oil pressure then dropped to nothing. I put on mechanical gage started engine gage had 40 pounds then dropped to zero lifters making more noise.Drained oil put a mixture of diesel fuel and auto tranny fluid started engine and let idle no oil pressure. drain mixt and put in new 10-40 oil and filter changed filter started engine no oil pressure. I am certain it needs new oil pump.Does anyone know if I can drop pan with engine in car or do I have to pull the engine to drop the pan.

Thanks for the help
 








smegun

Well-Known Member
Joined
April 3, 2013
Messages
386
Reaction score
3
City, State
florida
Year, Model & Trim Level
1994 ford explorer xlt
94 .....cant change the oil pump without pulling engine ?

any tutorial links for changing the oil pump and timing chain on 94 would be apreciated
 




jd4242

Explorer Addict
Joined
October 15, 2008
Messages
10,789
Reaction score
286
City, State
va beach
Year, Model & Trim Level
92explorer&94 ranger
Could be just a clogged screen, that happened to mine.I too have heard of people jacking the motor up and pulling it but dont know how, maybee with a body lift..if you replace it use a m328 HV pump
 




Top