Old Problem still exists | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

Old Problem still exists

Status
Not open for further replies.

Stinger357

Well-Known Member
Joined
November 8, 2010
Messages
114
Reaction score
0
City, State
Plano, Texas
Year, Model & Trim Level
1997 Ford Explorer Eddie
I was getting a misfire on 2 cylinders. So I had my mechanic chane the plugs to autolite (bouch was in them) And the wire he replaced. And my engine is still misfiring! I am going to change the ignition coil next. I will keep you posted. Any comments or suggestions please I need them.
 






swetrid

Explorer Addict
Joined
September 30, 2010
Messages
1,888
Reaction score
7
City, State
Reading Pa
Year, Model & Trim Level
1999 Eddie Bauer
Which cylinders are misfiring?
 






Stinger357

Well-Known Member
Joined
November 8, 2010
Messages
114
Reaction score
0
City, State
Plano, Texas
Year, Model & Trim Level
1997 Ford Explorer Eddie
it was cylinders 1 and 6. But my mech changed both those including the wires. Now the Truck seems to run a little better. NO more hesitation why taking off from a light. He suggested I change the ignition coil that might fix it. Also clean your MAF which I will a special screwdriver for that. But overall I am happy with the way it is running now. But it is getting error P0171 fuel trim bank. I am thinking I need to clean my maf and any sensors that I can clean..what are your thoughts??
 






Status
Not open for further replies.
Top