P0174 System too lean (Bank 2)??? | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

P0174 System too lean (Bank 2)???

CoachR

New Member
Joined
July 13, 2008
Messages
1
Reaction score
0
CEL came on so I went to autozone and got this reading P014 System too lean (Bank 2), however truck seems to run just fine. I have an 03 Sport trac 4x4, 4.0 SOHC v6. My neighbor and another buddy say to change the O2 sensor. ONly thing is will this fix it. ALso, I see 3 O2 sensors is that how mnay there are on this vehicle, or am I just not seeing on. My truck starts kind of slow and during the winter sometimes would die right after I started it. During the summer it has just been a little slow starting. I have 94K on it so figured I would change the spark plugs. SO my question is will changing the O2 sensor fix the problem, and which sensor do I need to change for Bank 2??
 
<



BrooklynBay

Moderator & long time member.
Staff member
Moderator
Elite Explorer
Joined
November 11, 2005
Messages
55,313
Reaction score
740
City, State
Brooklyn, NY
Year, Model & Trim Level
88 89 93 95 96 Aerostars
<



CDW6212R

Hauls the mail.
Elite Explorer
Joined
June 17, 2004
Messages
22,382
Reaction score
2,733
City, State
Knoxville, TN
Year, Model & Trim Level
98 Limited AWD
Ditto, plus mine was the fuel pressure, check that also(62psi). Welcome,
 
<



briwayjones

Manual Master
Joined
December 11, 2003
Messages
4,460
Reaction score
4
Location
Maryland, USA
City, State
Eldersburg, MD
Year, Model & Trim Level
2000 Ford Explorer XLS
If you've never changed the plugs and wires do that first. They can cause it. If it doesn't help it's probably still more likely that's it's some kind of vacuum leak than a bad O2 sensor.

Welcome to the forum.
 
<



Top