P0305 issue. Need help | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

P0305 issue. Need help

MountyMan06

New Member
Joined
December 5, 2017
Messages
7
Reaction score
1
City, State
Buffalo,ny
Year, Model & Trim Level
2006 mountaineer premier
So I'll start off with this. Got a p0305, stating ignition/fuel issue, misfire. 2006 mountaineer, 4.6L.

Found plug to be dead. Changed that. No resolve. Changed coil.. still misfiring. Changed fuel inj., still not helping. It will run slightly rough, not horrible. But as soon as its in gear, any gear, feels like it will stall and shakes bad. Now i noticed cyl 1 coil is cracked on top a bit, hooked up to computer, checked the spark duration on all 8cyl, one is acting a bit speratic. Will change this out but wondering if any of you have any other ideas besides changing this out. I'm not getting a cyl1 misfire, so that's why I'm curious.
 
<

Join the Elite Explorers $20 Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




ThunderbirdSport

Well-Known Member
Joined
August 4, 2013
Messages
324
Reaction score
59
Location
Thunderbird Heights
City, State
Missouri
Year, Model & Trim Level
2006 Eddie Bauer V8
If the coil is visually bad, why not replace it?

My money is on it being the culprit...
 
<



MountyMan06

New Member
Joined
December 5, 2017
Messages
7
Reaction score
1
City, State
Buffalo,ny
Year, Model & Trim Level
2006 mountaineer premier
If the coil is visually bad, why not replace it?

My money is on it being the culprit...


Update. CP and plug on cyl 1 did nothing to help. Tried to do a compression test but cant find a fitting to screw into cyl5 head. So im still at a loss.
 
<



Bill MacLeod

Well-Known Member
Joined
November 18, 2000
Messages
737
Reaction score
37
City, State
Hamilton, Ontario
Year, Model & Trim Level
06 Ltd V-8
You will need an M16 thread adapter for your compression tester. Lisle # 20380 should fit.
 
<



Explorer_PL

Elite Explorer
Joined
November 16, 2007
Messages
2,906
Reaction score
198
City, State
Rockland County, NY
Year, Model & Trim Level
06EB V8
Check each harness and plug going to each coil.
Replace the plugs with broken clips.
I had # 4 wires with insulation gone and it would actually stall the engine while driving and throw codes not related to the issue.
Took me 2 months to figure it out. I even replaced the intake runner module behind the intake twice since the codes were reading it to be bad. I think the old one was actually ok but the short was sending some weird messages to PCM.
 
<



Top