Painted Pillar Trim | Page 6 | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

Painted Pillar Trim

BigRondo

USMC 1371
Staff member
Moderator
Elite Explorer
Joined
February 15, 2010
Messages
7,845
Reaction score
16
City, State
Charlestown, RI
Year, Model & Trim Level
2014 Escape SE
I just checked the pillars after letting them dry for 3+ hours and they weren't smooth at all. The first time I did them they where very smooth throughout.

So I'm thinking that I might have been impatient. I resprayed the clear and this time I will give it the full 24 hours before tossing in the towel.

I will post up my results tomorrow at about this same time. Wish me luck. :p:
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





JoshMcMadMac

Explorer Addict
Joined
December 20, 2009
Messages
1,050
Reaction score
10
City, State
Waynesboro, PA
Year, Model & Trim Level
2002 Mercury Mountaineer
You have repainted several times in a very short period, which can also be an issue.
 






Doomstang

Member
Joined
February 12, 2011
Messages
45
Reaction score
1
City, State
St. Louis, MO
Year, Model & Trim Level
02 XLT and '91 XLT
I had painted my pillar trim a couple years ago and the roof rack looked fine at the time. However, in the last couple months I noticed the roof rack's paint went really quickly...it was suddenly half white and looked like crap.
So today I took the rack off, bead blasted it, dipped it in Alodine, and repainted it black...looks great again!
It wasn't that tough to do either...so if you are already gonna paint your pillar trim, take a careful look at the roof rack because it may not be far behind.
 






BigRondo

USMC 1371
Staff member
Moderator
Elite Explorer
Joined
February 15, 2010
Messages
7,845
Reaction score
16
City, State
Charlestown, RI
Year, Model & Trim Level
2014 Escape SE
The pillars came out pretty bad. I was hoping some time on the Ex in the sun would fix them but no luck there. I will get some pics up. All is not lost. I stumbled upon this thread last night: http://www.explorerforum.com/forums/showthread.php?t=353847

I don't know how I missed it. Looks like there may be some hope for the pillars after-all!! :biggthump

I plan on doing the roof racks too but I will cover that in a different thread.

Thanks again for all the help. :D
 






PDXplore

Member
Joined
October 14, 2011
Messages
25
Reaction score
0
City, State
PDX
Year, Model & Trim Level
2002 Explorer XLT Limited
BigRondo, I'm glad you found my thread and it gave you new hope.


I believe your problem was that you are using a gloss black and then trying to clear over that.

Basically, the slow-curing clear in the single stage black is reacting against the speed of the clear-only spay.

If you're doing a separate clear coat (2 stage) you can't use a gloss due to the different cure rates of the clears. You need to either: flat black>clear or just use a single stage (gloss) black.

Hope that helps a little. I would go into a little more detail but I'm all drugged up from a recent back surgery and it took me 30minutes to write what i did.
 






BigRondo

USMC 1371
Staff member
Moderator
Elite Explorer
Joined
February 15, 2010
Messages
7,845
Reaction score
16
City, State
Charlestown, RI
Year, Model & Trim Level
2014 Escape SE
BigRondo, I'm glad you found my thread and it gave you new hope.


I believe your problem was that you are using a gloss black and then trying to clear over that.

Basically, the slow-curing clear in the single stage black is reacting against the speed of the clear-only spay.

If you're doing a separate clear coat (2 stage) you can't use a gloss due to the different cure rates of the clears. You need to either: flat black>clear or just use a single stage (gloss) black.

Hope that helps a little. I would go into a little more detail but I'm all drugged up from a recent back surgery and it took me 30minutes to write what i did.

Thanks for the info. I had no idea. :dunno: I guess I will try it again with flat black and clear. I know mine won't come out as good as yours but I'm gonna try.

Hope you feel better soon. :thumbsup:
 






Tophat1962

New Member
Joined
December 17, 2014
Messages
6
Reaction score
0
City, State
Walker La.
Year, Model & Trim Level
2003 Explorer Limited AWD
I am going to do this to mine except body color which is mineral grey metallic.
 






ThatExplorerDude

Well-Known Member
Joined
March 11, 2015
Messages
173
Reaction score
0
City, State
Edmonton Alberta
Year, Model & Trim Level
1995&1997 explorer xlt
Sorry to revive yet another old thread (Im bad for that)... Would a similiar process be used for a 2nd generation Explorer???
 






Top