Pitman Arm Installation Problems | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

Pitman Arm Installation Problems

mhardy85

Member
Joined
November 10, 2007
Messages
11
Reaction score
0
City, State
Calgary, AB
Year, Model & Trim Level
94 XLT
Sorry if this has been covered before, but I tried searching and couldn't find what I'm looking for.

My steering gear box was leaking, so I removed it and replaced the seals. I now have everything back in the truck except I can't get the pitman arm to go back on the output shaft. I tried centering the steering wheel and the tires, but it won't go together. The pitman arm is still connected to the tie rods if that matters. The only way I can get it together gives me right turns but nothing to the left, so I obviously had the arm lined up wrong. Is there an easy way to get this lined up properly? I have a Chilton manual but that doesn't give me any help here. I fought with it for hours this evening with no luck, now I'm stuck without a vehicle for work tomorrow. If anyone can give me some help that would be great.
 
<



DeRocha

NEX Vice President
Elite Explorer
Moderator Emeritus
Joined
July 5, 2003
Messages
6,671
Reaction score
41
City, State
Brockton, MA
Year, Model & Trim Level
'93 XLT 4x4
You need to remove the pitman arm from the tie rod.. When its still connected it creates an additional force that will make trying to line up the splines on the steering gear with the pitman arm Very difficult.
 
<



<



mhardy85

Member
Joined
November 10, 2007
Messages
11
Reaction score
0
City, State
Calgary, AB
Year, Model & Trim Level
94 XLT
Got it fixed up. Not paying attention, I put the steering gear together off center, so nothing was lining up for me. It's all working perfect now with no leaks whatsoever. So much nicer to drive!
 
<



Top