Please Help: Car Won't Start, Makes Clicking Noise | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

Please Help: Car Won't Start, Makes Clicking Noise

goodbytes

New Member
Joined
March 15, 2013
Messages
9
Reaction score
0
City, State
Jacksonville, Fla
Year, Model & Trim Level
2001 Ford Explorer Sport
Got in the car this morning and tried to start it but it just made this weird clicking noise. Holding the ignition in start, the clicking continues as long as the key is held. All the indicator lights in the gauges blink in sync with the clicks and the drive belt moves a tiny bit with each click as well.
Is this a battery issue or the starter or some kind of short?
 
<



Bobmbx

Well-Known Member
Joined
May 6, 2013
Messages
947
Reaction score
9
City, State
King George, VA
Year, Model & Trim Level
2016 Explorer Platinum
Dead battery.

Try cleaning the battery terminals and restarting.

Oh, does it start with a jump?
 
<



goodbytes

New Member
Joined
March 15, 2013
Messages
9
Reaction score
0
City, State
Jacksonville, Fla
Year, Model & Trim Level
2001 Ford Explorer Sport
Yeah, it started right up with a jump. I guess I'll go somewhere and the battery tested. It is 5 years old anyhow.
That clicking sound is odd though. The last time my battery went bad almost nine years ago it just died--no crank or clicking
 
<



Bobmbx

Well-Known Member
Joined
May 6, 2013
Messages
947
Reaction score
9
City, State
King George, VA
Year, Model & Trim Level
2016 Explorer Platinum
Yeah, it started right up with a jump. I guess I'll go somewhere and the battery tested. It is 5 years old anyhow.
That clicking sound is odd though. The last time my battery went bad almost nine years ago it just died--no crank or clicking


Okay....a nearly dead battery. There's not enough current left to turn the starter, but enough to engage the starter solenoid. Thats the click you hear.

Its chattering, right?
 
<



Top