Please help me identify this part... | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership! If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

Please help me identify this part...

Mirge

Well-Known Member
Joined
November 27, 2009
Messages
413
Reaction score
0
City, State
Tulsa, OK
Year, Model & Trim Level
'98 Eddie Bauer
Snapped some pictures... it has 2 hoses connecting to it, looks like vacuum lines? The part that's bolted on there... has an electrical connection hooked into it. Not a clue what it is... but one of the hoses is broken off and stuffed w/ a bolt. I'm assuming that should be replaced. Looks like it has something to do with the EGR system somehow, so I'm wondering if that's what is throwing the P1403 code.

Please help!!! Thanks!
 


Holiday Special! Join the Elite Explorers $20 for 2 years! Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




Mirge

Well-Known Member
Joined
November 27, 2009
Messages
413
Reaction score
0
City, State
Tulsa, OK
Year, Model & Trim Level
'98 Eddie Bauer
Figures. As SOON as I post the pictures, I find the dang part... looks identical to what I'm trying to take pictures of from what I can tell lol..
 




alohamonte

Well-Known Member
Joined
October 4, 2007
Messages
786
Reaction score
4
City, State
Glendale, AZ
Year, Model & Trim Level
1998 Explorer 4.0 4x4
You'll want to replace the two hoses along with it. They degrade, come apart from the inside, and clog.
 




Mirge

Well-Known Member
Joined
November 27, 2009
Messages
413
Reaction score
0
City, State
Tulsa, OK
Year, Model & Trim Level
'98 Eddie Bauer
Hm... would autozone keep the hoses of (hopefully) correct length stocked? lol

Not sure how much of a pain it'll be to get to the one that seems to go towards an exhaust manifold..
 




2000StreetRod

Staff member
Moderator
Joined
May 26, 2009
Messages
10,599
Reaction score
273
City, State
Greenville, SC
Year, Model & Trim Level
00 Sport FI, 03 Ltd V8
Bad DPFE?

P1403 Differential Pressure Feedback Electronic Sensor Hoses Reversed

The above is very likely because there is no hose connection from the upstream port to the DPFE. Its very possible that you have a bad DPFE but at $55 you may want to find out for sure. The first thing I would do is replace the hose which you'll have to do whether the DPFE is good or bad. You can't just use fuel hose because of the high temperature. For more info see:
 




Mirge

Well-Known Member
Joined
November 27, 2009
Messages
413
Reaction score
0
City, State
Tulsa, OK
Year, Model & Trim Level
'98 Eddie Bauer
P1403 Differential Pressure Feedback Electronic Sensor Hoses Reversed

The above is very likely because there is no hose connection from the upstream port to the DPFE. Its very possible that you have a bad DPFE but at $55 you may want to find out for sure. The first thing I would do is replace the hose which you'll have to do whether the DPFE is good or bad. You can't just use fuel hose because of the high temperature. For more info see: /QUOTE]

Well, the part where the hose would connect to the sensor ... that little plastic portion that sticks out that the hose slips over... that is snapped clean off lol.
 








Mirge

Well-Known Member
Joined
November 27, 2009
Messages
413
Reaction score
0
City, State
Tulsa, OK
Year, Model & Trim Level
'98 Eddie Bauer
Well in that case there's no doubt about needing a new one.

LOL yeah... is there a special type of hose I need for this that I should ask for at the parts store?
 




mrboyle

I Drive By Brail
Moderator Emeritus
Joined
February 18, 1999
Messages
4,153
Reaction score
28
City, State
Montrose, CO
Year, Model & Trim Level
'95 Bronco '80 Toy
LOL yeah... is there a special type of hose I need for this that I should ask for at the parts store?

You will need a high tempature silicone hose.
 








Top