Please help | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Please help

Joined
February 20, 2010
Messages
33
Reaction score
0
City, State
Michigan City IN
Year, Model & Trim Level
1994 exploerexlt
when i go to turn my key to acc no start everything comes on but the check engine light and the explorer wont start. it has been doing this for awhile but usually after a couple tries the check engine would come on and the ex would start. i replaced the solenoid. all i can think of now is the computer. is there a way to check the computer? any help would be appreciated. or any other ideas
 






Usually, the PCM is "tested" by process of elimination -- if everything else checks out ok, then the PCM must be bad.

PCM's don't go bad very often. My first thought with the symptoms you describe is a fault in the main PCM power circuit (relay would be a good place to start checking).
 






Thank you for your response. I have checked the relays. i posted a thread called relay prob i think. and did not get any responses. now i am just lost. the whole problem started with me replacing the eec relay. i switched relays around to get her started i went to advance auto and bought a new relay. when i was switching relays back the alarm went off. and everytime i started the ex the alarm would go off. after about 6 times it would not do anything. no start finally got her started and bought her home. when i shut her off the alarm would go off? i put batteries in the keyfob cycled through it a few times and is has worked till now. i put a new solenoid on it but when i try to start her she will turn over fine but no start. it happened to me a couple times before when i turn the key on all the dash lights will come on except the check engine light and when i try to start her she just turns over. so i dont know what the _UCK is going on. no check engine light is why i am thinking pcm? Thank you
 






Today i got some contact cleaner took all the relays out and cleaned the relays and everything. also can someone tell me what the 2 diodes are for? cleaned them too and they were really dirty. i also took the computer out and sprayed the contacts and wiring harness. so far the ex has been starting no problems. but it has only been a couple hours though. thanks
 






Back
Top