• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^

Power Steering Gone

mbrando1994

Well-Known Member
Joined
May 17, 2015
Messages
275
Reaction score
6
Year, Model & Trim Level
2003 Ford Ex XLT
4.0 V6
Hi all,

I was helping someone learn how to drive today and I guess they turned the wheel to lock and held it there for too long. Now when I turn the wheel, the wheel shakes (not the car), there is a noticeable whining and surging noise only when steering, and there is also power steering fluid strewn all over the engine bay. I am assuming this is a failed pump. Would I be correct or could it be something else? Either way I'm worried and need to get it fixed asap!

2003 Explorer XLT 4.0L AWD
 




D Hook

Elite Explorer
Joined
October 10, 2010
Messages
1,060
Reaction score
41
City, State
Omaha, NE
Year, Model & Trim Level
06 Explorer Limited V-8
Possibly just blew a hose. The pump won't be far behind.
 




mbrando1994

Well-Known Member
Joined
May 17, 2015
Messages
275
Reaction score
6
Year, Model & Trim Level
2003 Ford Ex XLT
4.0 V6
Possibly just blew a hose. The pump won't be far behind.
So I should replace the hose and the pump? I know how to replace the pump, just not the hose.. how many hoses are there?
 




mbrando1994

Well-Known Member
Joined
May 17, 2015
Messages
275
Reaction score
6
Year, Model & Trim Level
2003 Ford Ex XLT
4.0 V6
Possibly just blew a hose. The pump won't be far behind.
On closer inspection it does appear as if the majority of leak/moisture is central to the pump area. I'm guessing it's the pump and possible a hose. I can't find anywhere how to replace them though.
 




Top