Power window cable | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

Power window cable

opgpc0

New Member
Joined
July 27, 2005
Messages
2
Reaction score
0
City, State
Huntingtion NY
Year, Model & Trim Level
1991 Explorer Eddie Bauer
Newbie here
The rear passenger window has stopped working. I hear the
motor working. I took off the door panel and somehow messed up the cables.
Can anyone give me any hints on the cable configuration. How do I go about taking the regulator out?


Thanks
Glen
 
<

Join the Elite Explorers $20 Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




Rick

Pumpkin Pilot
Staff member
Admin
Elite Explorer
Joined
February 8, 1999
Messages
33,456
Reaction score
1,787
City, State
Wayoutin, Aridzona
Year, Model & Trim Level
'93 XL Pumpkin Edition
Callsign
AB7FH
bump
 
<



pinoyesv6

Member
Joined
July 11, 2005
Messages
29
Reaction score
0
City, State
Maryland
Year, Model & Trim Level
'91 XLT
how'd you mess up the cables? what did you do to them? i didn't even mess with my cables. took the motor out, and took out the gear aassembly and changed the bushings.
 
<



opgpc0

New Member
Joined
July 27, 2005
Messages
2
Reaction score
0
City, State
Huntingtion NY
Year, Model & Trim Level
1991 Explorer Eddie Bauer
Messed up cables

I dont know,,,,Question is how do I go about fixing this. I am probablr better off taking the whole regulator out. How big a PITA is this?
 
<



pinoyesv6

Member
Joined
July 11, 2005
Messages
29
Reaction score
0
City, State
Maryland
Year, Model & Trim Level
'91 XLT
what makes you think you messed up the cable?


well there are rivets that hold the regulator. drill them out. but you have to remove the glass and the window guide also.
 
<



jreece04

Member
Joined
April 9, 2005
Messages
12
Reaction score
0
City, State
Tucson, AZ
Year, Model & Trim Level
'92 XLT
I am having the same problem with my 92 x I did a lot of searching here on explorerforum and what I thought would be the regulator sounds like it may be the bushing in the motor. you may want to search some more before you pull the entire regulator.
 
<



nuts883

New Member
Joined
April 8, 2005
Messages
2
Reaction score
0
City, State
Bloomington, IL
Year, Model & Trim Level
2002 Limited
I rolled my passenger front window down today and it would not go back up. I used this site to figure out how to take the door panel off and started checking things out. Some how my cables came loose from the window and were just flopping around inside the door. It was weird because it just stopped working all of a sudden. I now have two ends of a cable that go somewhere, but I'm pretty confused right now.
 
<



Tony H

Explorer Addict
Joined
September 4, 2003
Messages
1,594
Reaction score
1
City, State
New York, Wading River (that's on Long Island)
Year, Model & Trim Level
'91 Eddie Bauer
Big pain in the A$$. Drill out Rivets manipulate it out the tine holes in sheetmetal.
These cables are known for breaking on these first Gen Explorers
 
<



1-Dragon

Member
Joined
April 9, 2006
Messages
14
Reaction score
0
City, State
Bellevue,Nebraska
Year, Model & Trim Level
'93 4x4 XLT
my rear window did the same last weekend
I took the motor out to find out that the cable is totally shredded
i could not find out how the ends of the cable are attacked to the window regulator since for some odd reson ford decided to put them on the back side of the regulator instead on the front where u can get to them
I pulled up one of the cables and clamped it under the window rubber strip to hold the window up untill i have time and money to fix it
hope i can find some pictures since my chilton repair manual doesn't show much of it

Had the window on the passenger side fall out of the regulator last year and had to glue it back in with liquid nails
also put grease everywhere something moved in the regulator , it was going far to heavy and the motor had problems pulling it back up
Now its all going smooth and fast again

Those window meganisms seem to be pretty crappy
 
<



Top