Premium Audio in the 2014 Ford Explorer | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Premium Audio in the 2014 Ford Explorer

sjohnsonjd

New Member
Joined
May 2, 2014
Messages
9
Reaction score
0
City, State
Fontana, CA
Year, Model & Trim Level
2014 Ford Explorer
Dear Ford Owners,

I have a 2014 Ford Explorer with the Premium Audio system in an XLT with the Ford Sync. I had my old amp installed by Best Buy and the amp has had some noise coming out of the audio system. It grows every time I run the engine. Has anyone ever successfully replaced the head unit on their Ford Explorer XLT without ruining their Ford Sync?
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





Dear Ford Owners,

I have a 2014 Ford Explorer with the Premium Audio system in an XLT with the Ford Sync. I had my old amp installed by Best Buy and the amp has had some noise coming out of the audio system. It grows every time I run the engine. Has anyone ever successfully replaced the head unit on their Ford Explorer XLT without ruining their Ford Sync?
Sound like the issue maybe with the amp. Is the amp just the type to boost volume? I never had my volume setting much more than a 5th of the way up the volume scale because it would be too loud.

Peter
 

Attachments

  • P4250228_001.JPG
    P4250228_001.JPG
    50.3 KB · Views: 448






It could be with the amp, however it worked perfectly fine in my Jeep Cherokee. No noise. It does just increase the volume, with a bass boost.
 






It could be with the amp, however it worked perfectly fine in my Jeep Cherokee. No noise. It does just increase the volume, with a bass boost.

Since they messed up the install to begin with, I'd go back to BB.
 






Is it like a whine? If so, they make isolation filters for it. Could also be due to poor grounding.
 






If it's a whine just run the ground to the battery. They probably grounded it to the chassis. That's when you get the alternator whine through the amp.
 






Back
Top