• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^

Pro-M Mass Air Flow Sensor Failure

beast

Well-Known Member
Joined
June 30, 2003
Messages
193
Reaction score
0
City, State
Mukilteo, WA
Year, Model & Trim Level
92 XLT
I had my Pro-M sensor for about a year, everything seemed fine. The other day after work I went to start my car, and it just died after I started it, I finally got it to stay on long enough to feel a really rough idle before it died. I had to have it towed down to Ford to be fixed and they fouund it to be throwing off a code for the mass air flow sensor. So, they threw on the stock air flow sensor for me, and it works fine now. Anyone else have any problems with their Pro-Ms?
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.








BeauJ

Moderator Emeritus
Joined
January 23, 2002
Messages
4,596
Reaction score
4
I'm lost. How are you a wannabe but you have an avatar?
 




spindlecone

Explorer Addict
Joined
April 30, 2004
Messages
4,836
Reaction score
0
City, State
San Jose, Calif
Year, Model & Trim Level
2003 sport trac
Like me he has the platinum membership, we are above ELITE:)
 




beast

Well-Known Member
Joined
June 30, 2003
Messages
193
Reaction score
0
City, State
Mukilteo, WA
Year, Model & Trim Level
92 XLT
I was elite at one time, guess I never paid my dues. I guess I'll call up Pro-M and see what they can do for me.
 




celly

disturber of the peace
Joined
July 28, 2004
Messages
6,858
Reaction score
5
City, State
calgary
Year, Model & Trim Level
99 eb 5.0 awd
beast said:
I was elite at one time, guess I never paid my dues.

As good a time as any for a renewal.

(p.s. "Pro-Flow", makers of Pro-M went belly up. That company spindle mentioned is probably rising from the ashes. Caveat emptor).
 




spindlecone

Explorer Addict
Joined
April 30, 2004
Messages
4,836
Reaction score
0
City, State
San Jose, Calif
Year, Model & Trim Level
2003 sport trac
celly said:
As good a time as any for a renewal.

(p.s. "Pro-Flow", makers of Pro-M went belly up. That company spindle is probably rising from the ashes. Caveat emptor).
Know for a fact that it is a spin off, only game in town
 




Robb

Explorer Addict
Joined
February 13, 2002
Messages
9,716
Reaction score
4
I'm lost. Why are you posting in the 911 Forum if your truck runs fine?
 




performancenut

Well-Known Member
Joined
December 28, 2003
Messages
729
Reaction score
0
City, State
Eastern North Carolina
Year, Model & Trim Level
'97 XLT 5.0
beast said:
I was elite at one time, guess I never paid my dues. I guess I'll call up Pro-M and see what they can do for me.

Good luck calling them; they are out of business now.
 




beast

Well-Known Member
Joined
June 30, 2003
Messages
193
Reaction score
0
City, State
Mukilteo, WA
Year, Model & Trim Level
92 XLT
Sorry, this doesn't belong in Explorer 911. Well, I bought it through explorerexpress so hopefully they can help me if Pro-M did indeed go belly up.
 




Creager

Explorer Addict
Joined
October 11, 2004
Messages
2,782
Reaction score
4
City, State
Charlotte, NC
Year, Model & Trim Level
'92 Sport 4x4
i removed my pro-m MAF today, and reinstalled my stock ford MAF on the (Pro-M) 70mm bore... then reset the computer

i instantly saw that my truck idled down much sooner. With the Pro-M it would take 3 or 4 minutes to slowly idle down from 1200 rpm to 750 rpm.

After i put the stock ford MAF back on it took no longer then 15 seconds to go from 1200 rpm to 750 rpm.

Also the truck doesnt hesitate randomly (in the heat) like it did before. Ive also noticed that in 4th and 5th gear i dont get any spark knock, unlike the pro-M.

I think the Pro-M was causing my truck to run somewhat lean, which was in turn giving me great gas milage. might be reinstalling it haha probably not. Power > GasMilage.
 




Top