• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^

PS Pressure Line Leak!

MistahYebba

Well-Known Member
Joined
June 29, 2015
Messages
253
Reaction score
3
City, State
Clearwater, Florida
Year, Model & Trim Level
2005 Ford Explorer XLT
Hey guys!

My stock PS Pressure Line was spraying fluid all over the place... so naturally, I got a new one and replaced it.

The new one has been working fine for about a week now... but it just developed another leak!

Luckily, this leak isn't from a tear in the rubber hose... it's actually leaking from right above the nut connecting it to the steering rack. (is that what it's called; please quote me and correct me!)

Use this pic for example...

9e726abd2750d6ed120a82ac62ccaf50.png


It's leaking RIGHT ABOVE THE FREAKING NUT!!

So I tried to tighten it.. and it's as tight as can be!

What's the issue?

O-Ring cracked or faulty?

Will teflon tape fix it?

How could a brand new hose leak?!

UGH!
 




natenkiki2004

Blue Bomb!
Elite Explorer
Joined
November 3, 2013
Messages
2,044
Reaction score
77
Location
North Idaho
Year, Model & Trim Level
1991 & 1994 Explorers
Shouldn't be an o-ring in there, it's a flared tube with a NPT nut. It should simply tighten until the flared part of the tube is firmly seated against the port of the steering box.

I'd loosen it up and take a look at the mating surface. Could be that it's cross-threaded. I know when I did mine, I had a helluva time making sure the steering box end were going in right.
 




Top