RE: ABS/Cruise Control problem. Might have a fix | Page 3 | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

RE: ABS/Cruise Control problem. Might have a fix




Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





You are welcome! The search tool is a wonderful thing!
 






After getting a $700 repair estimate ("your cruise control actuator is burnt up" -- $500 parts, $200 labor) I decided I could do without cruise. Paid a $100 diagnostic fee (OUCH!). The forum saved me. Searched, replaced the defective sensor on the master cylinder, and voila! FIXED! And I got my $100 back. Great job, Forum!
 






This forum is definitely great. Cruise worked sometimes, but usually not after I hit the brakes. Also the ABS light was on and off intermittently. Dealer wanted $40 now for the part, but got the Motorcraft part listed in this forum for $21.00 online. Was going on a trip and the part had just come in. I was ready to drive off and thought, why don't I look under the hood and see how long this is going to take? 30 seconds tops. Fixed the problem with the cruise and ABS. wonderful.
 






...you stated they jumpered the switch to make the light go out. does anyone know how to jumper the switch?
 






Need a little help.... I thinking I may have the wrong part, but not sure. I have the replacement part specified above in this thread. The setup in my 2002 looks exactly like the diagram earlier in this thread. The part I have looks exactly the same as the one in the photo on that same posting. Where I'm confused is that they look like two different parts. The wiring harness will not fit for starters. What am I missing?
 






Need a little help.... I thinking I may have the wrong part, but not sure. I have the replacement part specified above in this thread. The setup in my 2002 looks exactly like the diagram earlier in this thread. The part I have looks exactly the same as the one in the photo on that same posting. Where I'm confused is that they look like two different parts. The wiring harness will not fit for starters. What am I missing?

If the wiring is different, for sure you were given the wrong part.
 






I installed the sensor but my cruise still doesnt work. Any other recommendations? I dont want to take it to the dealer. It costs $70 to run a dianostics.

With the car running, check to see if your brake lights are staying on w/o the brake being pressed. If so, it's the switch on the brake pedal preventing the cruise from engaging. Also, make sure the switch you replaced is identical to what's in the diagram currently at the bottom of this thread, not just its connector. The dealership replaced my fuse and connector as part of the recall but not the switch, so it didn't fix my cruise problem. They told me it was the servo, so I bought a used one for $80 and installed it myself. Lo & behold, it didn't fix my cruise (so I have an extra one if you'd like to buy it). I ended up buying the master cyl switch that Ford should've replaced and of course, problem solved.
 






I have a 2005, the switch is not the same as everyone else? Anyone have and Idea how I would/could remove the switch? It is on the top of the reservoir or on the bottom.
popup.php


This is what my tank looks like....
 












I have a 2005, the switch is not the same as everyone else? Anyone have and Idea how I would/could remove the switch? It is on the top of the reservoir or on the bottom.
popup.php


This is what my tank looks like....

go look at the brake pedal under the dash, do you see 2 brake switches?
 






Could you describe what the switches would look like? I see a yellow capsule looking thing, another switch looking thing (almost like a double fuse holder, its not but looks like it) and then another thing near the brake that has a plug. I can not post pictures Or would post whats under my dash. Thanks again for your time.
 






Could you describe what the switches would look like? I see a yellow capsule looking thing, another switch looking thing (almost like a double fuse holder, its not but looks like it) and then another thing near the brake that has a plug. I can not post pictures Or would post whats under my dash. Thanks again for your time.

if you have traction control, you should have 2 switches on your brake pedal under the dash. one would be the brake switch which would have the yellow thing over it, the other would be a push pin type switch.
 






yes I have the Yellow capped switch you said and then I have Blue/White plug style near the pedal and then lastly a black plug (this is the one that looks like two inline fuses together?)
 






black / white or black / blue cant remember they made them a different color every year. you should have 2 connectors, one to the switch with the yellow thing, then one just above it to the left, a connector with 2 wires, that if you press the brakes down a plug comes out that's the cruise deactivation switch for someone with traction control.
 






OK, I think I found what you are taking about. Would this cause my cruise not to engage? How is this replaced?
 






OK, I think I found what you are taking about. Would this cause my cruise not to engage? How is this replaced?

yes you can test it, use a fuse in the connector if it works, just replace the switch.
 






hopefully last question, it looks like it would hold two fuses. Should I put one in both and what amp would you suggest?
 






hopefully last question, it looks like it would hold two fuses. Should I put one in both and what amp would you suggest?

one fuse, with 2 leads on it, 5 or 10amp put it across the connector, not the one with the yellow thing the one above it, the one with the yellow is a brake switch, you dont want to drive with brake lights on.

all you are doing is removing the switch, and putting a fuse in 5 or 10 amp in the switches place.
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





Hey Guys,
I have the same problem with the ABS light staying on but my cruise control still works. Any suggestions?
 






Back
Top