• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^

rear brakes not working

rsw2008

My 95 EX EB
Joined
November 16, 2008
Messages
70
Reaction score
1
Location
pine grove ca
City, State
pine grove, ca.
Year, Model & Trim Level
91 xlt 95 ex eb
91 xlt 4.0. Rabs light is on all the time, front brakes locking up on hard braking. Was told that a piston was stuck in the bottom of the master cylinder or the rabs unit.there seems to be no braking on the rear axle.

this is only one of many problems with this thing.
 
Join the Elite Explorers for $20.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.


ricco750

Active Member
Joined
December 2, 2005
Messages
267
Reaction score
0
City, State
Springfield, MO USA
Year, Model & Trim Level
'93XLT4X2 (3:27 LimSlip)
91 xlt 4.0. Rabs light is on all the time, front brakes locking up on hard braking. Was told that a piston was stuck in the bottom of the master cylinder or the rabs unit.there seems to be no braking on the rear axle.

this is only one of many problems with this thing.
Do you have a question? It certainly sounds like you need at least a new master cylinder.:usa:
 

04sd

Member
Joined
December 20, 2007
Messages
53
Reaction score
0
City, State
pa
Year, Model & Trim Level
'05 F150, '84 Ranger
91 xlt 4.0. Rabs light is on all the time, front brakes locking up on hard braking. Was told that a piston was stuck in the bottom of the master cylinder or the rabs unit.there seems to be no braking on the rear axle.

this is only one of many problems with this thing.
On my '90 Bronco the RABS unit was bad resulting in no fluid making it to the rear. I removed the unit and ran a new line directly to the rear. IMHO the early rear only ABS was garbage and never did work well so just get rid of it. I bought a '92 Ranger new with the RABS and could easily lock up a rear tire on a wet road.
 

rsw2008

My 95 EX EB
Joined
November 16, 2008
Messages
70
Reaction score
1
Location
pine grove ca
City, State
pine grove, ca.
Year, Model & Trim Level
91 xlt 95 ex eb
rear brake problems

yea i was thinking of eliminating the rabs unit,but iwanted some input from the guru's before i did it. it looks like i can just take it out and install a line in the place of it. ill check the master cyl. just to make sure. living in a motel now, so there's not much i can do here.

thank's guys! will update later!
 

mcelwajy

Member
Joined
August 8, 2008
Messages
75
Reaction score
0
City, State
Monroe, OH
Year, Model & Trim Level
1993 Eddie Bauer
I just dealt with the stupidity that is the RABS system. There were spider webs in my drums....they weren't doing anything. Upon bleeding them , no pressure at all was going to the rear. Ended up being the RABS hydraulic unit mounted in the frame rail. 115 at O'reilley with a lifetime warranty. SO now they work, but my ABS light is on....wonderful....good luck
 

Top