• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^


kkeb

New Member
Joined
February 24, 2011
Messages
14
Reaction score
0
City, State
O-H-I-O!
Was running errands, and everything was fine. Except at one point, my backup camera stopped coming on. The sensors still beep, but instead of the camera shot, I get my home screen. And, the Ford logo that normally appears when I start the car, is gone.

Anyone else run into this problem?

It's at the dealer and the service guy is trying to tell me it has to do with the Sirrius update. SERIOUSLY? The Sirrius switch was a month ago, and my backup camera went out 3 days ago. In addition, how can a satellite radio company changing its programming affect my backup camera?

I have a feeling this is going to end badly...and after having my Buick in for constant nit-picky things since the day it was "born", I have less patience for this stuff. Got the car Easter weekend, and it's already in the shop. Not happy.
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




jrmexplorer

Well-Known Member
Joined
April 19, 2011
Messages
1,109
Reaction score
1
Year, Model & Trim Level
2011 Limited
Was running errands, and everything was fine. Except at one point, my backup camera stopped coming on. The sensors still beep, but instead of the camera shot, I get my home screen. And, the Ford logo that normally appears when I start the car, is gone.

Anyone else run into this problem?

It's at the dealer and the service guy is trying to tell me it has to do with the Sirrius update. SERIOUSLY? The Sirrius switch was a month ago, and my backup camera went out 3 days ago. In addition, how can a satellite radio company changing its programming affect my backup camera?

I have a feeling this is going to end badly...and after having my Buick in for constant nit-picky things since the day it was "born", I have less patience for this stuff. Got the car Easter weekend, and it's already in the shop. Not happy.
"It's at the dealer and the service guy is trying to tell me it has to do with the Sirrius update. SERIOUSLY? The Sirrius switch was a month ago, and my backup camera went out 3 days ago. In addition, how can a satellite radio company changing its programming affect my backup camera?"

That's the first I've heard of the "Sirius" update causing MFT to perform poorly. If MFT is that poorly designed God help us all. More likely is that your dealer doesn't know jack squat about MFT

What I would do is try restarting the car a few times. If that doesn't work, pull fuse #29 to reset MFT. It's hard to get to (above the parking brake on the driver's side) but it resolves a lot of issues.

If that doesn't work - take it to a different dealer. If they can't help you send a private message to Cory whose username is FordCustSrvc - he's a Ford rep who answers questions on these boards. He has helped members get issues resolved in the past
 




kappaknight

Member
Joined
March 14, 2011
Messages
79
Reaction score
0
City, State
Atlanta, GA
If I've learned anything over the past few days, it's that sales people know almost nothing about the things they sell. Whether it's correct or not, they just try to sound confident in whatever answer they give you so you'll buy the story.

It's a shame... a few hours of training (and retraining) could go a loooong way.
 




techieman33

Explorer Addict
Joined
January 29, 2005
Messages
7,997
Reaction score
3
City, State
Topeka, KS
Year, Model & Trim Level
00 V8 Mountaineer
It's a first year vehicle, it's going to have some bugs that need to be worked out. And the dealerships aren't going to have a lot of experience dealing with the problems since they still haven't seen to many yet. It's just going to take time and some patience.
 




jjs461

New Member
Joined
March 4, 2011
Messages
48
Reaction score
0
City, State
Philadelphia, PA
Year, Model & Trim Level
2011 Limited
It's a first year vehicle, it's going to have some bugs that need to be worked out. And the dealerships aren't going to have a lot of experience dealing with the problems since they still haven't seen to many yet. It's just going to take time and some patience.
I don't recall seeing a 1st year discount when I purchased the vehicle. These bugs should have been worked out before releasing the vehicle. I shouldn't have to be looking under my dash to find a fuze to pull out to reset a system, this is totaly unacceptable.
 




GTMD

Member
Joined
February 9, 2011
Messages
84
Reaction score
1
City, State
Ohio
Year, Model & Trim Level
2011 LIMITED
I don't recall seeing a 1st year discount when I purchased the vehicle. These bugs should have been worked out before releasing the vehicle. I shouldn't have to be looking under my dash to find a fuze to pull out to reset a system, this is totaly unacceptable.
Agreed,there are some bugs to be worked out.On the other hand,when my home pc locks up I "ctrl.,alt.,del.".,on the Explorer you "master reset".If my home pc is still locked up I "power down",on the X you pull a fuse or disconnect the battery.Just your pc on your vehicle.
 
Last edited by a moderator:




thesthompson

New Member
Joined
May 31, 2011
Messages
4
Reaction score
0
City, State
TN
Year, Model & Trim Level
2011 Limited
discount

No Joke, we should all get a big rebate back!
 




Loganfilm

Elite Explorer
Joined
February 27, 2011
Messages
253
Reaction score
0
City, State
Santa Monica, CA
Year, Model & Trim Level
'11 Limited 4WD
Actually, they should scrap Microsoft and hire Apple to write a better interface... That actually works.

Paying good money to be Beta testers is unacceptable. We should have been told this and, yes, provided a discount to reflect the hours and hours wasted learning and then teaching dealers how to fix our brand new cars.

Mine gave me card read errors three times yesterday. I had to reach down, pull it out, and reinsert it several times. Nearly got into an accident. It's all so distracting.

Also, the nav took over ten minutes to kick in, the few times when it did Decide to "work". I'm constantly in and out of my car, so this system is completely useless to me and frustrated me more and more with each short trip. The lack of traffic integration makes it laughable. What did we pay for?

I've been playing phone tag with a Ford rep for nearly a week. If. Miss his call, it's back to endless voicemail. Seems appropriate with the way this crap MFT system works.

I'm thoroughly unimpressed with the execution of what should be great tech advances. It's all there... Please make it work!
 




FordService

Official Ford Rep
Joined
October 25, 2010
Messages
5,281
Reaction score
12
City, State
Dearborn, MI
Year, Model & Trim Level
2014
Was running errands, and everything was fine. Except at one point, my backup camera stopped coming on. The sensors still beep, but instead of the camera shot, I get my home screen. And, the Ford logo that normally appears when I start the car, is gone.

Anyone else run into this problem?

It's at the dealer and the service guy is trying to tell me it has to do with the Sirrius update. SERIOUSLY? The Sirrius switch was a month ago, and my backup camera went out 3 days ago. In addition, how can a satellite radio company changing its programming affect my backup camera?

I have a feeling this is going to end badly...and after having my Buick in for constant nit-picky things since the day it was "born", I have less patience for this stuff. Got the car Easter weekend, and it's already in the shop. Not happy.
Thank you so much for the recommendation jrmexplorer. With something as frustrating as this, I’d like to reach out to offer my assistance by escalating your concern. If you are OK with sending me a PM with your VIN, approximate mileage, and dealer name, I’ll be happy to do this to help resolve the issues you are experiencing.

Loganfilm, please let me know with a private message when it’s a better time for you to be contacted so this can be avoided in the future.

Cory
 




kkeb

New Member
Joined
February 24, 2011
Messages
14
Reaction score
0
City, State
O-H-I-O!
Just an update. I requested that my service person look into the problem instead of returning the car (I wasn't going to accept that a satellite radio program change caused my backup camera to stop working). He fixed the problem, but this was the explaination: "It had something to do with something plugged into your USB port. I cannot explain how I fixed it, but now it is fixed."

Huh?

Well, the only thing plugged into a port was my lowly Ipod (not even an Ipod Touch, mind you). So now, I guess my IPod can cause my backup camera to puke out. (I have not plugged it back in to see what happens.)

In addition, my car was returned and all of my settings are back to the factory setting, so now I will spend another half an hour going through and figuring out what needs reset to my preferences.

I am glad it is fixed, and I know there are bugs, but really...
 




FordService

Official Ford Rep
Joined
October 25, 2010
Messages
5,281
Reaction score
12
City, State
Dearborn, MI
Year, Model & Trim Level
2014
Just an update. I requested that my service person look into the problem instead of returning the car (I wasn't going to accept that a satellite radio program change caused my backup camera to stop working). He fixed the problem, but this was the explaination: "It had something to do with something plugged into your USB port. I cannot explain how I fixed it, but now it is fixed."

Huh?

Well, the only thing plugged into a port was my lowly Ipod (not even an Ipod Touch, mind you). So now, I guess my IPod can cause my backup camera to puke out. (I have not plugged it back in to see what happens.)

In addition, my car was returned and all of my settings are back to the factory setting, so now I will spend another half an hour going through and figuring out what needs reset to my preferences.

I am glad it is fixed, and I know there are bugs, but really...
Thank you for the update. I agree that changing your settings back to how you like it is a bit tedious, but I’m glad it’s fixed now too. If you have any other issues and would like my help, please don’t hesitate to message me here.

Cory
 




jrmexplorer

Well-Known Member
Joined
April 19, 2011
Messages
1,109
Reaction score
1
Year, Model & Trim Level
2011 Limited
Just an update. I requested that my service person look into the problem instead of returning the car (I wasn't going to accept that a satellite radio program change caused my backup camera to stop working). He fixed the problem, but this was the explaination: "It had something to do with something plugged into your USB port. I cannot explain how I fixed it, but now it is fixed."

Huh?

Well, the only thing plugged into a port was my lowly Ipod (not even an Ipod Touch, mind you). So now, I guess my IPod can cause my backup camera to puke out. (I have not plugged it back in to see what happens.)

In addition, my car was returned and all of my settings are back to the factory setting, so now I will spend another half an hour going through and figuring out what needs reset to my preferences.

I am glad it is fixed, and I know there are bugs, but really...
I can tell you what the tech did right now based on the fact that your settings are all erased - If your settings were all reset the tech disconnected your battery cable, let it sit for 10 minutes and reconnected it. He did a hard reboot of MFT (my ford touch/MS Sync). It has nothing to do with your iPod.
 




dco43054

Well-Known Member
Joined
April 24, 2003
Messages
1,291
Reaction score
9
City, State
cmh
Year, Model & Trim Level
16 XLT
I've been playing phone tag with a Ford rep for nearly a week. If. Miss his call, it's back to endless voicemail. Seems appropriate with the way this crap MFT system works.

I'm thoroughly unimpressed with the execution of what should be great tech advances. It's all there... Please make it work!
So a Ford Rep has been trying to get in touch with you for a week now to work out how to fix your problems?

:dunno:

Sounds like they are trying to get your issue resolved.
 




StunnedMonkey

Active Member
Joined
April 8, 2011
Messages
237
Reaction score
0
City, State
Fort Wayne, IN
Year, Model & Trim Level
2011 XLT
I can tell you what the tech did right now based on the fact that your settings are all erased - If your settings were all reset the tech disconnected your battery cable, let it sit for 10 minutes and reconnected it. He did a hard reboot of MFT (my ford touch/MS Sync). It has nothing to do with your iPod.
Does disconnecting the battery reset ALL of the settings? I've done this twice, and while it seems to do things like forget my phone pairing, erase my phonebook, and reset my preferences in the various Settings menus, it doesn't clear things such as my radio and Sirius presets...which makes me wonder if I'm getting a full reset.
 




ezridermn

New Member
Joined
March 20, 2012
Messages
16
Reaction score
0
City, State
Forest Lake, MN
Year, Model & Trim Level
2014 Explorer Sport
Rear Camera Problem

I have a 2011 Ford Explorer Limited. I just installed the new MyTouch software upgrade that has come out in recent weeks. Most everything seems to be working as it should except the Rear Camera.

When I put the vehicle in reverse the camera comes on and I get a good view of what is behind me. However, it will not display any of the visual color guides. In addition the Zoom function doesn't work. The Zoom button is there and when I select it the Zoom in and out arrows are there but when I push them nothing happens.

I have checked the vehicle settings several times to ensure all the visual guides actions are properly activated. I even tried various combinations of on and off to see if that would make anything work and nothing did.

Anybody have any suggestions as to what might be going on and what I can do to fix it?

Thanks in advance for your help!
 




jrmexplorer

Well-Known Member
Joined
April 19, 2011
Messages
1,109
Reaction score
1
Year, Model & Trim Level
2011 Limited
I have a 2011 Ford Explorer Limited. I just installed the new MyTouch software upgrade that has come out in recent weeks. Most everything seems to be working as it should except the Rear Camera.

When I put the vehicle in reverse the camera comes on and I get a good view of what is behind me. However, it will not display any of the visual color guides. In addition the Zoom function doesn't work. The Zoom button is there and when I select it the Zoom in and out arrows are there but when I push them nothing happens.

I have checked the vehicle settings several times to ensure all the visual guides actions are properly activated. I even tried various combinations of on and off to see if that would make anything work and nothing did.

Anybody have any suggestions as to what might be going on and what I can do to fix it?

Thanks in advance for your help!
Did you try a fuse 29 pull? Try that. I've seen lots of people with some instability right after upgrading and the fuse pull takes care of it.
 




peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
28,165
Reaction score
1,681
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
Did you try a fuse 29 pull? Try that. I've seen lots of people with some instability right after upgrading and the fuse pull takes care of it.
With the number of times fuse 29 seems to require pulling in and out, perhaps Ford should think about locating it in the cubby hole next to the USB ports.:D

Peter
 




jrmexplorer

Well-Known Member
Joined
April 19, 2011
Messages
1,109
Reaction score
1
Year, Model & Trim Level
2011 Limited
With the number of times fuse 29 seems to require pulling in and out, perhaps Ford should think about locating it in the cubby hole next to the USB ports.:D

Peter
Agreed!
 




ezridermn

New Member
Joined
March 20, 2012
Messages
16
Reaction score
0
City, State
Forest Lake, MN
Year, Model & Trim Level
2014 Explorer Sport
Rear Camera Problem

Thanks for the suggestions. I will give it a try and let you know what happens.
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




rmp301

Active Member
Joined
October 19, 2011
Messages
313
Reaction score
0
City, State
Yonkers, New York
Year, Model & Trim Level
2012 Explorer XLT
With the number of times fuse 29 seems to require pulling in and out, perhaps Ford should think about locating it in the cubby hole next to the USB ports.:D

Peter
Seems that we should have a power shutoff switch located at the battery for just such issues. Then we could just disable the battery and reconnect again with this switch. You gotta luv it! :mad:
 




Thread starter Similar threads Forum Replies Date
K 2011 Rearview camera and blind spot sensor (BLIS) issue 2011-2016 My Ford Touch / In Vehicle Technology 2
J 2012 Rearview Camera from 2015 2011-2016 My Ford Touch / In Vehicle Technology 5
C 2013 Explorer Rearview Camera Issue 2011-2016 My Ford Touch / In Vehicle Technology 3
C Rearview camera view backwards 2011-2016 My Ford Touch / In Vehicle Technology 8
F Rearview Camera Active Guidelines 2011-2016 My Ford Touch / In Vehicle Technology 92
N 2016 Explorer Sport Front Camera Doesn't Work 2011-2016 My Ford Touch / In Vehicle Technology 1
C backup camera diagnose and replace APIM 2011-2016 My Ford Touch / In Vehicle Technology 12
B Radio/Back up Camera stops working 2011-2016 My Ford Touch / In Vehicle Technology 4
P Backup camera directional guides 2011-2016 My Ford Touch / In Vehicle Technology 2
K Touch screen intermittently not responsive and backup camera issues 2011-2016 My Ford Touch / In Vehicle Technology 4
M Sync/Phone/Camera Issues 2011-2016 My Ford Touch / In Vehicle Technology 3
C Backup Camera and boat launching 2011-2016 My Ford Touch / In Vehicle Technology 3
G Installing Backup Camera and 8" Screen in my 2013 Explorer - Is it possible? 2011-2016 My Ford Touch / In Vehicle Technology 3
M Front Camera 2011-2016 My Ford Touch / In Vehicle Technology 8
J Adding Back Up Camera - It can be done on the OEM screen 2011-2016 My Ford Touch / In Vehicle Technology 4
B Rear bumper replaced now camera grainy 2011-2016 My Ford Touch / In Vehicle Technology 5
R Rear View Camera when towing 2011-2016 My Ford Touch / In Vehicle Technology 12
V Rear view/back-up camera in 2014 is different from 2008 ? 2011-2016 My Ford Touch / In Vehicle Technology 5
C Backup camera alarm 2011-2016 My Ford Touch / In Vehicle Technology 15
D Backup Camera screen cancel button - did it disappear in 3.5.1? 2011-2016 My Ford Touch / In Vehicle Technology 5
B Rear Camera - No Guidelines Show 2011-2016 My Ford Touch / In Vehicle Technology 164
H V2.7 Backup Camera 2011-2016 My Ford Touch / In Vehicle Technology 20
Eltee Phonebook Download Problems 2011-2016 My Ford Touch / In Vehicle Technology 9
W 2011 Explorer XLT - Radio Problems 2011-2016 My Ford Touch / In Vehicle Technology 2
Daheim111 A "how to" to not have problems with MFT ? 2011-2016 My Ford Touch / In Vehicle Technology 7
B Hands free phone call problems 2011-2016 My Ford Touch / In Vehicle Technology 13
R Winter Problems with Auto HVAC Temp 2011-2016 My Ford Touch / In Vehicle Technology 4
E iOS8/iphone 6/MFT/Sync - Problems with BT calling 2011-2016 My Ford Touch / In Vehicle Technology 13
M My Ford Touch Problems- Software Update 2011-2016 My Ford Touch / In Vehicle Technology 13
P Ambient Lighting Problems 2011-2016 My Ford Touch / In Vehicle Technology 283
T 2013 explorer limited problems 2011-2016 My Ford Touch / In Vehicle Technology 6
C Update 3.5.1 first problems 2011-2016 My Ford Touch / In Vehicle Technology 15
D Problems w Nav After 3.5 Update 2011-2016 My Ford Touch / In Vehicle Technology 4
D New MFT Update - Old Problems persist 2011-2016 My Ford Touch / In Vehicle Technology 3
S SYNC Problems and the underlying story 2011-2016 My Ford Touch / In Vehicle Technology 9
F MFT Update - Now More Problems 2011-2016 My Ford Touch / In Vehicle Technology 7
L Major problems AFTER doing Master Reset! What to do now? 2011-2016 My Ford Touch / In Vehicle Technology 4
S General Sound Problems 2011-2016 My Ford Touch / In Vehicle Technology 5
B Climate Control problems after update? 2011-2016 My Ford Touch / In Vehicle Technology 6
scottfmc Upgraded: SYNC Problems remain 2011-2016 My Ford Touch / In Vehicle Technology 29
L Nav system problems 2011-2016 My Ford Touch / In Vehicle Technology 6
S Am i the only person that has no problems with mft? 2011-2016 My Ford Touch / In Vehicle Technology 42
J Official Explorer MFT Problems / Issues / Feature Suggestions Thread 2011-2016 My Ford Touch / In Vehicle Technology 205
1 Problems with SYNC. 2011-2016 My Ford Touch / In Vehicle Technology 41
1 MyFordTouch Sync problems 2011-2016 My Ford Touch / In Vehicle Technology 31

Similar threads

Top