Replacing stock amp | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Replacing stock amp

drmarten621

Member
Joined
June 2, 2002
Messages
10
Reaction score
0
City, State
portland, or
Year, Model & Trim Level
95 XLT w/JBL Audio
I want to replace the stock subwoofer amp in my explorer (95 XLT with JBL audio) and I want to know if anybody either knows the wiring diagram for the stock jbl audio amp, or where I can find it.
(can't wait to get my new amp in!)

Thanks.
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





update...

Today i connected what I thought was power (wish I had a voltometer right about now..) and blew the 20 amp fuse in my amp...oops. that was the red and yellow wires. I replaced the fuse and when I connect the red black and white (which i figured to be pos grnd and remote) the amp would never power on.

Any assistance would be appreciated...

THANKS
 






i odnt know the stock sub amp wiring, but if you are testing for power, make sure you have an inline fuse on the wire so you dont damage anything.
 






yup

gone throuigh 3 of em already....
 






Large black wire from top harness= ground
green and yellow(pretty sures thats the color) from top harness= positve

grey wire from main amp on bottom... there should be 3 wires coming out of it. The black one is the remote, the sheilded one is your positive input and the bare one is negative input.

The other harness is the positive and negative leads to the speaker. The positive is the solid black. The other is negative.

Mine has been running great since.
 






THANK YOU!

THANK YOU VERY MUCH!
I have been screwing with it for a while and just could not figure it out for the life of me....too impacient i guess.
 












Back
Top