Rough engine idle and miss | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

Rough engine idle and miss

Oxthe3rd

Active Member
Joined
August 4, 2015
Messages
92
Reaction score
1
City, State
Hamburg NY
Year, Model & Trim Level
1992 Ford Explorer XLT
I was driving when my 1992 developed a miss randomly buy very noticeable. I got home ran a koeo and koer test and got 157 and 158 on koeo and 159 on koer. I believe that's for maf sensor. When running I unplugged the sensor with no change to the rough idle.

Any ideas before I get a new maf?
 
<

Join the Elite Explorers $20 Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




natenkiki2004

Blue Bomb!
Elite Explorer
Joined
November 3, 2013
Messages
2,044
Reaction score
77
Location
North Idaho
Year, Model & Trim Level
1991 & 1994 Explorers
Grab some cleaner and clean the hot wires off. People say you must only use MAF cleaner but that stuff is expensive. I've used Brake Parts cleaner without issue. Vinegar as well but you need to let it soak. Whatever you do, don't touch the wires or brush them. Liquid only, no compressed air.
 
<



malohnes

Well-Known Member
Joined
August 8, 2009
Messages
909
Reaction score
14
City, State
SE Alaska
Year, Model & Trim Level
'91 xl m5 4x4
Electrical contact cleaner works better than brake cleaner for the MAS sensor. Definitely clean it first before buying a new one. Reset the engine computer too.
 
<



FixingDaily

Active Member
Joined
September 17, 2010
Messages
51
Reaction score
0
City, State
Boise, Idaho
Year, Model & Trim Level
94 Explorer XLT
Electrical contact cleaner works better than brake cleaner for the MAS sensor. Definitely clean it first before buying a new one. Reset the engine computer too.

I would add that you should use the "No Residue" type electrical contact cleaner. There is also the type of cleaner with a lubricant added that may mess things up.
 
<



Oxthe3rd

Active Member
Joined
August 4, 2015
Messages
92
Reaction score
1
City, State
Hamburg NY
Year, Model & Trim Level
1992 Ford Explorer XLT
Alright so I cleaned the sensor with contact cleaner and letting it dry over night. I think i found what caused it. I have a decent amount of oil coming in from the oil fill tube into the intake that sprayed all over.
 
<



Oxthe3rd

Active Member
Joined
August 4, 2015
Messages
92
Reaction score
1
City, State
Hamburg NY
Year, Model & Trim Level
1992 Ford Explorer XLT
Cleaned MAF sensor solved most of the misfire but i still have a miss at steady throttle around 2000 rpm. It doesn't happen constantly but does set off the check engine light. check engine shuts off almost immediately after.

Im going to try to pull any codes i can and will update. I think im going to change the fuel filter and check my plugs although the plugs were changed recently.
 
<



Oxthe3rd

Active Member
Joined
August 4, 2015
Messages
92
Reaction score
1
City, State
Hamburg NY
Year, Model & Trim Level
1992 Ford Explorer XLT
Finally replaced the mass airflow sensor and its all fixed
 
<



pkn

Well-Known Member
Joined
May 16, 2011
Messages
147
Reaction score
4
City, State
Houston, TX
Year, Model & Trim Level
'92 '05 '10 2WDstockXLTs
Finally replaced the mass airflow sensor and its all fixed
Thanks for posting back. It is important to know -- what worked... and what didn't.
 
<



Top