rough idle | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

rough idle

XLT FAN

New Member
Joined
February 28, 2007
Messages
9
Reaction score
0
City, State
DUB CITY, PA
Year, Model & Trim Level
1992 explorer XLT
hi gang. 92 x 4.0 auto. have developed a rough idle condition. new plugs and wires no cure. no miss, just a rough running motor. almost feels like a plug wire off, but like i said, no miss. fire on all cylinders. oh, new fuel filter also. any ideas? thank you
 
<

Join the Elite Explorers $20 Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




boggs1227

Explorer Addict
Joined
February 19, 2008
Messages
1,472
Reaction score
4
City, State
Flowery Branch , Georgia, 1994 sport 2wd auto
Year, Model & Trim Level
2005 colorado 2wd 5spd
maf ? any cel ? a week ago i went and drove mine and the cel came on and what it was was the wireing harness for the maf .it was just barelly on there
(was not on all the way or became loose) ...but when it was messing up the engine would idle some what ruff.maybe this is not wrong with yours but maybe the maf could use a cleaning . also see if the fpr (fuel pressure regulator) has a leak in the vac line and or the unit has failed .also the iac could use cleaning (idle air control ) .

hope this helps .

oh forgot to ask ...what type of plugs did you buy? that may be a the cause as well ?
 
<



<



XLT FAN

New Member
Joined
February 28, 2007
Messages
9
Reaction score
0
City, State
DUB CITY, PA
Year, Model & Trim Level
1992 explorer XLT
no vacuum leaks that i can find. oddly enough, no cel either. good idea about the harness. checked out ok. will try the maf cleaning.just out of curiosity.......ran the symptoms by a friend of mine, and he stated although rare, if the weight would break or drop off the flywheel, this would give you my exact symptoms. anyone ever heard of this happening? also told me to check the dampener pully for broken rubber.i guess this would make it turn funny thus vibrating the whole car via the motor. im running out of ideas here!
 
<



boggs1227

Explorer Addict
Joined
February 19, 2008
Messages
1,472
Reaction score
4
City, State
Flowery Branch , Georgia, 1994 sport 2wd auto
Year, Model & Trim Level
2005 colorado 2wd 5spd
!? wow never heard of that but hey anything can happen i suppose.if it is a weight that fell off the flywheel maybe you could take the starter loose and feel around in the bellhouseing and see if there is any metal fragments in there .also if the harmonic dampener pully is shot ...see if you can move it by hand ( just a long shot tho) ...see if there is a lot of play in it (may have to take the serpintine belt off to do that properlly) .

also what about the plugs you installed (another long shot) would be to put the old plugs back in and see if you still have problems.
 
<



Top