Running Boards - DeeZee and Others | Page 14 | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Running Boards - DeeZee and Others

Well, mine arrived last week. Been raining here for the last week and awaiting a dry day to install. After reading the comments here, I decided I better inspect mine. The shipping box for the rails was indeed damaged and I could see the end of the rails sticking out. I opened up the box, and all four ends had damage, two I could have lived with, but the other two were bent and abraded badly. Bummer. Sealed them back up and requested a return. I guess I will find something else to do this weekend.
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





Guys, these running boards look great. Has anyone with molded splash guards installed these? Curious as to whether or not they interfere with factory molded guards.
 












Hey Razziel24. You must be travelling down some pretty harsh roads. Those bends in the tabs are the result of some pretty heavy damage. Your running boards look to be years old instead of 6 months. A friend of mine has the same set up as this and his don't have any damage whatsoever. Can you tell me if you have been driving on some terrain that would have your boards striking the ground. I've seen damage like this before. It was a result of 4 wheeling. The bends in your pictures aren't from log term stress. Those are from blunt strikes and bangs. I'm an engineer and deal with stresses on metals. You must have also bent some in the uninstall process.
 












Guys, these running boards look great. Has anyone with molded splash guards installed these? Curious as to whether or not they interfere with factory molded guards.

There's a pic in this very threadshowing that they work with the molded guards........ PAGE 5
 






I am sorry to hear that some folks here are having problems with these DeeZee running boards when it comes to their delivery. I can honestly say that I have ordered two sets of the same running boards for my 2012 Explorer Limited and my 2013 Explorer Sport from Auto Anything and they have been delivered in excellent condition with no damage to either the boards or the brackets both delivered via UPS. You can check my threads here on both Explorers with the running boards. I have two friends that also ordered them for their Explorers from Auto Anything and they arrived in excellent condition via UPS as well.
Don't get me wrong , I know things can go wrong with some deliveries but I feel that those that have been affected should try ordering them again and see what happens the second time around.

I have installed them myself and it only took me less than an hour in each Explorer. There is no drilling required at all and they look amazing.

Best, Carlos

These are photos of my 2013 Explorer Sport with the DeeZee Running Boards,


D73-0220BBB21BAE-1439-0000008DA465B1AC_zps193bf47d.jpg


ExplorerSport2_zpsb45e02c8.jpg




ExplorerSport24_zps10fd1bc7.jpg



ExplorerSport22_zpscfb94721.jpg



ExplorerSport10_zps9a7ab550.jpg


DSC04921_zpse9aa054b.jpg



and these photos are for the 2012 Explorer Limited,


MyExplorer.jpg




MyExplorer2.jpg




MyExplorer1.jpg




DSC04517.jpg



DSC04516.jpg





DSC04515.jpg




DSC04523.jpg



DSC04522.jpg



DSC04485.jpg




DSC04480.jpg
 






Mine are backordered from CARiD.com. Being shipped on 22 Mar. I'll let everyone know how it turns out. Delivery and install.
 






There is absolutely nothing wrong with these running boards from DeeZee. I have installed them in two of my Explorers and there has never been a problem with them. I am 6'1' and 190lbs and I stand on them when I am cleaning the top of the Explorers and there are never been any problems. They install pretty easy and there is no drilling required. I have installed mine in less than an hour and they look amazing!!! I highly recommed them.
 






I am sorry to hear that some folks here are having problems with these DeeZee running boards when it comes to their delivery. I can honestly say that I have ordered two sets of the same running boards for my 2012 Explorer Limited and my 2013 Explorer Sport from Auto Anything and they have been delivered in excellent condition with no damage to either the boards or the brackets both delivered via UPS. You can check my threads here on both Explorers with the running boards. I have two friends that also ordered them for their Explorers from Auto Anything and they arrived in excellent condition via UPS as well.
Don't get me wrong , I know things can go wrong with some deliveries but I feel that those that have been affected should try ordering them again and see what happens the second time around.

I have installed them myself and it only took me less than an hour in each Explorer. There is no drilling required at all and they look amazing.

Best, Carlos

You sold me Carlos, they look GREAT on your white Sport!
Bet they will look good on mine too
 






Has anyone else received a shipment lately that can confirm if packaging has improved? Also, to address the gap concerns, has anyone put in a product like the one listed on these Westin boards? (see related products half way down the page. Couldn't find them on their own page)

http://www.autoanything.com/nerf-bars/61A3795A0A0.aspx

I'm a new explorer owner and board member. Looking to get boards, mats, and possibly deflectors all from auto anything if the boards truly do ship in improved packaging.
 






You sold me Carlos, they look GREAT on your white Sport!
Bet they will look good on mine too

You are very welcome Fast Gator. I am only trying to be as helpful as possible to all my peers in the forum based on my own experiences and providing the best photos possible of the equipment installed in my Sport.

I am pretty sure they will look amazing on your sport as well.

Best of luck!

B2D-346B9BFDDFD1-4877-000001F5733B8A7F_zps2cfbbba0.jpg



406-14EB841D25E5-4877-000001F570055030_zps3232f78b.jpg



B46-B93F6EBB3A2E-4877-000001C1EF82CB96_zpsf9c693b0.jpg


E6B-C9BAD5305DD4-4877-000001C1ED435193_zpsa1b1275d.jpg
 






Has anyone else received a shipment lately that can confirm if packaging has improved?

I received my running boards from AutoAnything at the end of February and they arrived in perfect condition. The box with the boards had styrofoam wrapped in cardboard at each end to protect the tips.

The mounting hardware came in a separate box and the brackets and bolts were just tossed in without additional packaging but these parts are rugged so no harm done. There was about a one inch hole gouged in this box though, presumably from the shifting hardware. It's conceivable that a bag of bolts could be lost through such a hole, but everything made it through in my shipment.

Also, I believe the delivery came via FedEx Ground and not UPS, so AutoAnything might have changed delivery companies.
 






Thanks for the followup, RogDog. Good to know the boards made it to the Bay Area intact and protected! I'll be placing my order today!
 






There is absolutely nothing wrong with these running boards from DeeZee. I have installed them in two of my Explorers and there has never been a problem with them. I am 6'1' and 190lbs and I stand on them when I am cleaning the top of the Explorers and there are never been any problems. They install pretty easy and there is no drilling required. I have installed mine in less than an hour and they look amazing!!! I highly recommed them.

Lucky you, I like the way they look, but quality could be inproved a bit
 






Running Boards

Does anybody have any pictures of their Explorer with running boards? I've seen the DeeZee boards and they look nice. I was also considering the ATS SL series boards.

Does anybody have any pics of their EX with ATS running boards installed? Thanks!
 






I'd love to post up some pics. My Dee Zee running boards have been on backorder for over a month now. Carid.com is starting to try my patience. I sent an email last week and just got a reply back today that they are checking on the status. I was told it would be delivered on 22 March. It's now the end of March and they still haven't cofirmed the boards have even been made. Sorry for jacking your post. Had to get it off my chest. LOL.
 






Anybody with any ATS SL series boards???
 






For sale I have a set of ARIES® S223041-2 - 4" Stainless Steel Oval Side Bars for the Ford Explorer 2011-2013.
Had them on the EX for about three weeks before I pulled them off. Nothing wrong with them but a small dent under one of them. Can't see it when there on the truck. They go for $356 new. Best offer takes them.

20130108_082958.jpg
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





JosERW: Here is a photo of the ATS SL Series of running boards. We sell an awful lot of these running boards for this vehicle. They are offered in either the with or without factory mud guards installed or not versions.

11ExplorerSLBoards.jpg


Does anybody have any pictures of their Explorer with running boards? I've seen the DeeZee boards and they look nice. I was also considering the ATS SL series boards.

Does anybody have any pics of their EX with ATS running boards installed? Thanks!
 






Back
Top