Running rich | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

Running rich

Kevinh71047

Active Member
Joined
June 12, 2018
Messages
51
Reaction score
0
City, State
Tenaha texas
Year, Model & Trim Level
1993 EXPLORER eddie Bauer
I have a 93 EXPLORER eddie Bauer 4.0

Whats going on is it s idling rough running to rich drinks lots of gas.changed plugs feul filter oxygen sensors maf sensor with new pigtail I did a eec test my codes is 157 and 998. It did do ok till about a few weeks ago till my light stays on. But even It went off and on my rpm gauge jumped and feels like it ain't shifting into last gear.
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




Mbrooks420

High Voltage.
Elite Explorer
Joined
February 2, 2002
Messages
11,680
Reaction score
2,270
Year, Model & Trim Level
1998 Mountaineer AWD
Were any of the plugs “cleaner” than the other? You could have a sticking fuel injector. If your CEL is flashing you probably have a misfire.
 




Kevinh71047

Active Member
Joined
June 12, 2018
Messages
51
Reaction score
0
City, State
Tenaha texas
Year, Model & Trim Level
1993 EXPLORER eddie Bauer
My plugs Are clean I have not checked the injectors what did you mean my cell light. Check engine light is always on.
 




Kevinh71047

Active Member
Joined
June 12, 2018
Messages
51
Reaction score
0
City, State
Tenaha texas
Year, Model & Trim Level
1993 EXPLORER eddie Bauer
Were any of the plugs “cleaner” than the other? You could have a sticking fuel injector. If your CEL is flashing you probably have a misfire.
Were any of the plugs “cleaner” than the other? You could have a sticking fuel injector. If your CEL is flashing you probably have a misfire.

What if I used gumout complete duel cleaner but I already used a bottle of this about a few weeks ago
 




Mbrooks420

High Voltage.
Elite Explorer
Joined
February 2, 2002
Messages
11,680
Reaction score
2,270
Year, Model & Trim Level
1998 Mountaineer AWD
If you find one plug cleaner than the rest it often points to a coolant leak in that cylinder, or a sticking injector. CEL=check engine light. If you clear the codes do they come right back? How old are the wires?
 




Kevinh71047

Active Member
Joined
June 12, 2018
Messages
51
Reaction score
0
City, State
Tenaha texas
Year, Model & Trim Level
1993 EXPLORER eddie Bauer
If you find one plug cleaner than the rest it often points to a coolant leak in that cylinder, or a sticking injector. CEL=check engine light. If you clear the codes do they come right back? How old are the wires?

Yes the light comes back on.
 




Kevinh71047

Active Member
Joined
June 12, 2018
Messages
51
Reaction score
0
City, State
Tenaha texas
Year, Model & Trim Level
1993 EXPLORER eddie Bauer
If you find one plug cleaner than the rest it often points to a coolant leak in that cylinder, or a sticking injector. CEL=check engine light. If you clear the codes do they come right back? How old are the wires?

Well the plugs ain't to old and the spark plug are not wet just got a little carbon is all.
 




Mbrooks420

High Voltage.
Elite Explorer
Joined
February 2, 2002
Messages
11,680
Reaction score
2,270
Year, Model & Trim Level
1998 Mountaineer AWD
I’d check the MAF wiring. The plugs likely wouldn’t be wet. How old are the wires?
 








Mbrooks420

High Voltage.
Elite Explorer
Joined
February 2, 2002
Messages
11,680
Reaction score
2,270
Year, Model & Trim Level
1998 Mountaineer AWD
You checked it all the way back to the computer? I’d check the MAF with a multimeter.
 








Mbrooks420

High Voltage.
Elite Explorer
Joined
February 2, 2002
Messages
11,680
Reaction score
2,270
Year, Model & Trim Level
1998 Mountaineer AWD
If MAF checks out and ALL the wiring ( not just the connector) is good you probably need a new computer.
 




Kevinh71047

Active Member
Joined
June 12, 2018
Messages
51
Reaction score
0
City, State
Tenaha texas
Year, Model & Trim Level
1993 EXPLORER eddie Bauer
If MAF checks out and ALL the wiring ( not just the connector) is good you probably need a new computer.

Well weeks just looked at the pc and it don't have a black wire on it to test it or does that black wire go somewhere else
 




roscoe 0202

Well-Known Member
Joined
February 3, 2014
Messages
340
Reaction score
76
City, State
salt lake city utah
Year, Model & Trim Level
1999 explorer sport
check your o2 senser
roscoe
 








Mbrooks420

High Voltage.
Elite Explorer
Joined
February 2, 2002
Messages
11,680
Reaction score
2,270
Year, Model & Trim Level
1998 Mountaineer AWD
Are you sure they are correct? Did you get the upstream and downstream ones in the correct place?
 




Kevinh71047

Active Member
Joined
June 12, 2018
Messages
51
Reaction score
0
City, State
Tenaha texas
Year, Model & Trim Level
1993 EXPLORER eddie Bauer
Yes they are in th e right place
 




Mbrooks420

High Voltage.
Elite Explorer
Joined
February 2, 2002
Messages
11,680
Reaction score
2,270
Year, Model & Trim Level
1998 Mountaineer AWD
Since you have checked everything and are sure it’s good in the harness and the sensors, I’d grab a junkyard computer for your model year and drivetrain package. I’m not sure what else it could be.
 




Kevinh71047

Active Member
Joined
June 12, 2018
Messages
51
Reaction score
0
City, State
Tenaha texas
Year, Model & Trim Level
1993 EXPLORER eddie Bauer
What a drivetrain package
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




Kevinh71047

Active Member
Joined
June 12, 2018
Messages
51
Reaction score
0
City, State
Tenaha texas
Year, Model & Trim Level
1993 EXPLORER eddie Bauer
Plus my koeo says Hard faults present. And it say limp mode
 




Top