Server-side email form? | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

Server-side email form?

section525

sextion525
Elite Explorer
Moderator Emeritus
Joined
February 11, 2001
Messages
14,763
Reaction score
29
City, State
Red Bluff, Ca
Year, Model & Trim Level
1975 Ford Bronco 4x4
Here is my form and I need to make it email to a certain email address. How do I go about doing this? I know I need to upload a dealio to the server.

Can someone explain this to a retard? Thanks.

http://www.necsports.com/insider.html
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





huskyfan23

Rah no Hans Bwix
Joined
November 21, 2002
Messages
6,721
Reaction score
6
City, State
WA
Year, Model & Trim Level
1994 XLT 4x4
So it's going to more than one e-mail? Or goes to an e-mail depending on what the user chooses?
 






section525

sextion525
Elite Explorer
Moderator Emeritus
Joined
February 11, 2001
Messages
14,763
Reaction score
29
City, State
Red Bluff, Ca
Year, Model & Trim Level
1975 Ford Bronco 4x4
Just one email address. Some ho-mail account.
 






huskyfan23

Rah no Hans Bwix
Joined
November 21, 2002
Messages
6,721
Reaction score
6
City, State
WA
Year, Model & Trim Level
1994 XLT 4x4
So you want something like a PHP form?
 






section525

sextion525
Elite Explorer
Moderator Emeritus
Joined
February 11, 2001
Messages
14,763
Reaction score
29
City, State
Red Bluff, Ca
Year, Model & Trim Level
1975 Ford Bronco 4x4
Suuure. Is that what I need? Remember, I am a we todd.
 






EliteConcept

Explorer Addict
Joined
June 5, 2001
Messages
4,056
Reaction score
0
City, State
LaPorte, Indiana
Year, Model & Trim Level
04 Civic LX
so you want a user to fill out the form then the results are sent to a hotmail account?
 






section525

sextion525
Elite Explorer
Moderator Emeritus
Joined
February 11, 2001
Messages
14,763
Reaction score
29
City, State
Red Bluff, Ca
Year, Model & Trim Level
1975 Ford Bronco 4x4
Tru dat! :D
 






EliteConcept

Explorer Addict
Joined
June 5, 2001
Messages
4,056
Reaction score
0
City, State
LaPorte, Indiana
Year, Model & Trim Level
04 Civic LX
ok i know i've done this, i just can't remember exactly how to do it...give me just a few and i'll hunt it up..and we'll have ya set
 






EliteConcept

Explorer Addict
Joined
June 5, 2001
Messages
4,056
Reaction score
0
City, State
LaPorte, Indiana
Year, Model & Trim Level
04 Civic LX
i know there is a easy way...grrr

check this out see if it helps
http://www.htmlgoodies.com/tutors/forms.html

what i found when i tried it...is that it works, however when i recieved the mail it was a .att format....i just saved it on my computer and changed the .att to .txt and it worked fine..but there is an easier way...but i can't think right now its been a long day.
:)
 






section525

sextion525
Elite Explorer
Moderator Emeritus
Joined
February 11, 2001
Messages
14,763
Reaction score
29
City, State
Red Bluff, Ca
Year, Model & Trim Level
1975 Ford Bronco 4x4
Hmm... I tried it. It worked. (Cept for the whole .att thing). I've have to screw around with it a little more. Thanks for your help though! :cool:
 






huskyfan23

Rah no Hans Bwix
Joined
November 21, 2002
Messages
6,721
Reaction score
6
City, State
WA
Year, Model & Trim Level
1994 XLT 4x4
This may help. I prefer server-side because there's that stupid little pop-up with HTML mailto forms. http://www.huskyfan23.com/section525 - Get both files, edit all lines in form.html that have a hidden input type. This should work for you, if you rename any of the forms on the HTML page you will also have to rename those in mail.php - It may take a few minutes for the e-mail to get to you, just depends on how busy your server is.
 






section525

sextion525
Elite Explorer
Moderator Emeritus
Joined
February 11, 2001
Messages
14,763
Reaction score
29
City, State
Red Bluff, Ca
Year, Model & Trim Level
1975 Ford Bronco 4x4
Husky.. the php file is giving me problems. I get this:

Parse error: parse error in /home/huskyfan/public_html/section525/mail.php on line 13

What am I doing wrong? Can I just open the php in Dreamweaver? Because when I do all it says is what's in the quotes up there. Thanks for your help!
 






huskyfan23

Rah no Hans Bwix
Joined
November 21, 2002
Messages
6,721
Reaction score
6
City, State
WA
Year, Model & Trim Level
1994 XLT 4x4
Ok. Sorry about that. Didn't test it before I uploaded it.
 






huskyfan23

Rah no Hans Bwix
Joined
November 21, 2002
Messages
6,721
Reaction score
6
City, State
WA
Year, Model & Trim Level
1994 XLT 4x4
Simple fix. Forgot a quote. Yes it can be opened in any editor, but if you aren't changing any of the form names in form.html, you don't need to edit the .php file.
 






section525

sextion525
Elite Explorer
Moderator Emeritus
Joined
February 11, 2001
Messages
14,763
Reaction score
29
City, State
Red Bluff, Ca
Year, Model & Trim Level
1975 Ford Bronco 4x4






huskyfan23

Rah no Hans Bwix
Joined
November 21, 2002
Messages
6,721
Reaction score
6
City, State
WA
Year, Model & Trim Level
1994 XLT 4x4
Alright. I'm assuming you might've added message wrong, I fixed it and tested it to my e-mail address, everything worked great. www.huskyfan23.com/section525 has the new stuff. For future reference, whenever you add another field, whatever the name is, has to be added to mail.php after Message, or wherever you want it to show up when e-mailed. So if you added Phone, in mail.php you would add Phone: (or whatever you want it to say when e-mailed) $FIELDNAME.
 






section525

sextion525
Elite Explorer
Moderator Emeritus
Joined
February 11, 2001
Messages
14,763
Reaction score
29
City, State
Red Bluff, Ca
Year, Model & Trim Level
1975 Ford Bronco 4x4
Hmm.. I didn't change anything. I just downloaded the stuff, then uploaded it to mine. I tried it again and it still does the same thing. But it works when I do it from your server. So that must mean something is getting screwy in the download or upload, right? Do I need to upload it in ASCII or something? :confused: Thanks again for helping the forum idiot. :D
 






huskyfan23

Rah no Hans Bwix
Joined
November 21, 2002
Messages
6,721
Reaction score
6
City, State
WA
Year, Model & Trim Level
1994 XLT 4x4
I'm thinking maybe your server doesn't have sendmail installed.. Download www.huskyfan23.com/php.php and run it on your server, then post what you get when running it.
 






Top