Service RSC, ABS | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! Once registered you can join the Elite Explorers to eliminate ads from the website.

Service RSC, ABS

Boozel

New Member
Joined
December 2, 2018
Messages
2
Reaction score
0
City, State
McVeytown, PA
Year, Model & Trim Level
2008 Mercury Mountaineer
I just joined, and I'm at my wits end with my 08 Mountsineer. The Service RSC came on intermittently awhile back, I did nothing and it went away. I had a wheel bearing go bad and the ABS light came on and off. Changed the wheel bearing, now RSC is on, ABS is on, stability light is on, and power is reduced. I thought I over-tightened the axle nut, so I backed it off, and there was no change. What did I do wrong?
 






Rcflyer330

Well-Known Member
Joined
March 23, 2014
Messages
772
Reaction score
84
City, State
Michigan
Year, Model & Trim Level
2010 Ford Explorer XLT V6
First you need to get the abs codes pulled. Was it the front or rear bearing that went bad? Lastly did you check and make sure the abs sensor is plugged in?
 






MotorCityFats13

Explorer Addict
Joined
January 25, 2015
Messages
1,080
Reaction score
79
City, State
Flatrock MI
Year, Model & Trim Level
2007 Explorer XLT 4.0L
I had all those pop up when I had a bad front abs sensor..... a code reader will show you if all 4 sensors are reading a speed
 






Boozel

New Member
Joined
December 2, 2018
Messages
2
Reaction score
0
City, State
McVeytown, PA
Year, Model & Trim Level
2008 Mercury Mountaineer
First you need to get the abs codes pulled. Was it the front or rear bearing that went bad? Lastly did you check and make sure the abs sensor is plugged in?
I'm going to the garage this afternoon to get codes pulled. It was the drivers front and yes I checked the ABS sensor plug.
 






Top