Shifter linkage issues | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Shifter linkage issues

Fedupwithford

New Member
Joined
May 11, 2016
Messages
5
Reaction score
0
Year, Model & Trim Level
2003 ford explorer xls
I have a 2003 ford explorer and we just replaced the transmission, now trying to get everything going and suddenly the column shifter slips through the gears and isn't shifting properly. I need help, I can't seem to find a darn thing on the Internet. If I need to tighten the shifter linkage how do I do that? Or is it something else all together?
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.











Unfortunately no,the cut off for that is 2001 I have a 2003 it looks completely different so I can't even find that bracket.
 






^ You posted in the 2001-05 ST sub forum. (Same as Gen 2) :D
 






Then I wonder why mine looks completely diffrent...
 












None of these are helping, Its a four door 2wd 2003, the pictures people say about the bracket looks 100 nothing like my steering column and shifter. I think I may have found a bracket that kind of looks like it. My shifter cable is kind of attached to it but the bolts dont seem loose at all. When I go to shift, underneath when the cable attaches to the tranny doesnt move enough, and the shifter pretty much just skips all the gears and doesnt lock into a single gear at all. almost as if the cable werent attached at all. Im dying here we thought replacing the tranny would be simple and on our way.
 












That first link I think might actually help!!! Thank you so much!
 






Back
Top