should i replace it or drive it til it breaks? | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

should i replace it or drive it til it breaks?

baehan

Active Member
Joined
May 18, 2002
Messages
85
Reaction score
0
City, State
Tempe, AZ
Year, Model & Trim Level
92 XLT 4WD
the speed governor is still sticking. i took it to my mechanic and he said that the fluid had some metal traces in there. i got the transmission flushed and went back after a month to check on the fluid. he said that there was some metal filings still coming back. is it the filings that continue to get the speed governor stuck? is it likely that he didn't flush everything out? the speed governor will be fine for a month after the fluid change, but then the symptoms will begin again. i have to drive it to 4k rpms before it will finally kick out of first (on a cold engine). after that...everything is fine. what could be causing the metal shavings? will replacing the speed governor remedy the situation? should i just replace the speed governor anyway. is there anything i can add to the fluid to help with the situation? how much is it to replace the transmission if i just drove it til the transmission is dead? thanks guys for all your help.
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





Crankcase

Moderator Emeritus
Moderator Emeritus
Joined
September 29, 2001
Messages
9,264
Reaction score
2
City, State
Vancouver B.C, Canada
Year, Model & Trim Level
1992 XL Ex-Police
It would definitley be cheaper to replace the govenor, than spend 1500 for a rebuild later:eek:
 






jimbo74

Elite Exploder
Joined
December 27, 2000
Messages
18,414
Reaction score
22
City, State
Nor*Cal
Year, Model & Trim Level
2001, F150, XLT 4x4
i thought the governor has nothing to do with the tranny itself, but is a computer actuated shutoff function.... is the speed gov damaged or are you refering to the torque converter?
 






Mbrooks420

High Voltage.
Elite Explorer
Joined
February 2, 2002
Messages
13,632
Reaction score
4,360
Year, Model & Trim Level
1998 Mountaineer AWD
A 4k 1-2 shift will kill a cold engine in short order. Add an engine to the $1,500+ for your trans if ya don't get it fixed.;)
 






Opera House

Explorer Addict
Joined
August 19, 2002
Messages
2,106
Reaction score
4
City, State
Cincinnati, OH
Year, Model & Trim Level
2014 Explorer 3.5L base
Add an inline filter

I just put one of the oil filter types tp my 5R55E cause it's starting to show a little metal in the pan. Just about ready to open the filter at 4K and see how it's working. On my 92 A4LD, the lockup in the TC went out and I went for years changing the fluid every eight months. I put four extra magnets in the pan and they would get thickly covered in metal powder. It never did fail. Pulling the transmission now because the fluid looks like motor oil in only a month. Did drop the reverse servo piston and it had almost 1/4 inch of sediment in it. I found four needle bearings in the filter of another A4LD and it still drove without a sound. Funny how some will stop with just a speck of dust!
 






baehan

Active Member
Joined
May 18, 2002
Messages
85
Reaction score
0
City, State
Tempe, AZ
Year, Model & Trim Level
92 XLT 4WD
jimabena74...i have the same symptoms as the post of the SPEED GOVERNOR WOES Dead Link Removed . that's why i assumed that it was the speed governor. i do not know too much about the mechanics of what is going on. i do not know if the speed gov is damaged.

operahouse...did you put an oil filter on the transmission? i don't understand what you did. could you clarify please?
 






Top