slipping a4ld | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

slipping a4ld

thewishkah

Explorer Addict
Joined
August 17, 2004
Messages
1,236
Reaction score
1
City, State
Brooklyn New York
Year, Model & Trim Level
1994 explorer xlt
Ok so yesterday I was driving and I noticed the rpms were in the 4500 range and I was only going 30 mph so I let off the gas and as I did it dropped in rpm's then it finally dropped into 2nd? then I went to park it and when I went into reverse and hit the gas i went no where then banged into reverse at like 2000 rpm. Is it about to go? if so when it goes is it worth it to go to the 700r? and how much would a shop charge to do the switch over with the kit, another rebuild is going to cost me 1700$ and it would be # 6 I cant deal with this horrible transmission anymore. This truck is getting on my nerves too 2000$ within 2 weeks= water pump, 4 tires, brakes,fan clutch, upper lower ball joints, radius arm bushings and mounts, and now this ugh sorry for venting. Any advice/ recomendations would be greatly apreciated


thank you . Jon
 






410Fortune

Truck Season!!
Staff member
Moderator
Joined
August 3, 2000
Messages
28,704
Reaction score
5,053
City, State
NORTH IDAHO, 7B
Year, Model & Trim Level
B2 "Slightly" Modified
Callsign
FOURTEN
check the fluid level
 






thewishkah

Explorer Addict
Joined
August 17, 2004
Messages
1,236
Reaction score
1
City, State
Brooklyn New York
Year, Model & Trim Level
1994 explorer xlt
I did check it and it was exactly where it was supposed to be on the cross hatched lines @ idle with warm engine on a flat surface. I checked it right then in the parking lot.
 






TPLYNCH

Explorer Addict
Joined
November 19, 1999
Messages
3,195
Reaction score
5
City, State
Brewster, NY
Year, Model & Trim Level
1999 XLS
Search for "low/reverse servo". I think that may be your problem.
 






Top