Sluggish Explorer | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

Sluggish Explorer

ROLLTIDE

New Member
Joined
August 4, 2010
Messages
2
Reaction score
0
Year, Model & Trim Level
1994
1994 Explorer 5 speed transmission has rough idle. Becomes real sluggish no power, I push gas pedal to the floor and speed up it clears up and will go. Then when I let off and slow down it becomes sluggish again. Does not do it in every gear, it changes, sometime in 3rd and 4th. No lights on dash to read. Checked the fuel pump pressure and it was at 32. What else can I check?
 






Iron Weasel

Well-Known Member
Joined
March 22, 2010
Messages
610
Reaction score
2
City, State
Belen, New Mexico
Year, Model & Trim Level
1994 XLT 4x4
Was the fuel pressure KOEO (Key On, Engine Off) or KOER (Key On, Engine Running)?

KOEO: 35psi - 45psi
KOER: 30psi - 40psi

Start the engine, put it in neutral then mash the throttle up to 3500 RPM or so. Does it sputter and run rough on the way up?

As for the fuel pressure, 32psi is OK if the engine was running but low if the engine was off. If it was while the engine was off, replace the fuel filter and re-check the fuel pressure. Also, remove the MAF sensor, it'll require a T20 security (tamper proof) Torx bit, and clean it off. Napa and the other parts places should carry MAF Sensor Cleaner - don't use carburetor cleaner.

Lastly, the CEL (Check Engine Light) may be off, but you might want to scan it and see if there are any codes in there anyway. The PCM might see a problem, but not all DTC's will turn the light on. It's an older EEC-IV system, so Autozone probably won't be able to scan it, but you might be able to slip a local shop $10 or something to have them scan it. If you're rather do it yourself, go to this thread http://www.explorerforum.com/forums/showthread.php?t=255962.
 






Top