Smoky! | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

Smoky!

explorerwbw

Member
Joined
November 9, 2010
Messages
24
Reaction score
0
City, State
South Carolina
Year, Model & Trim Level
96 V8 AWD Explorer
I was driving today and my left turn signal got stuck on! The green arrow was solid, not flashing on my instrument cluster. It slowly faded off and then a wisp of smoke came out of the hazard flasher button. Is this a multi-function switch problem?
 






bobflood

Elite Explorer
Joined
May 27, 2010
Messages
1,578
Reaction score
34
City, State
Powder Springs, GA
Year, Model & Trim Level
1997 Eddie Bauer V8 2WD
I was driving today and my left turn signal got stuck on! The green arrow was solid, not flashing on my instrument cluster. It slowly faded off and then a wisp of smoke came out of the hazard flasher button. Is this a multi-function switch problem?

Most likely - smoke there is definitely not a good thing.
 






explorerwbw

Member
Joined
November 9, 2010
Messages
24
Reaction score
0
City, State
South Carolina
Year, Model & Trim Level
96 V8 AWD Explorer
About how much is that in parts and labor? We had to do it in my mother's 1998 Range Rover and I remember it was hundreds of dollars.
 






bobflood

Elite Explorer
Joined
May 27, 2010
Messages
1,578
Reaction score
34
City, State
Powder Springs, GA
Year, Model & Trim Level
1997 Eddie Bauer V8 2WD
About how much is that in parts and labor? We had to do it in my mother's 1998 Range Rover and I remember it was hundreds of dollars.

Replacing multifunction switch is easy. I got one for $16 from a Pull-A-Part yard; took me about 30 mins to replace. Hardest part was unscrewing the tilt lever to take off the steeering column shroud. Haynes manual has excellent instructions for this. Replaced switch in 08 and still fine.
 






Top