speedometer acting up | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

speedometer acting up

andy93explorer

New Member
Joined
October 10, 2011
Messages
3
Reaction score
0
Year, Model & Trim Level
1993 Explorer 4x4 2DR
I was going down the interstate today running about 65 with the cruise set, when my speedometer jumped all the way up to 85. After that it keep reading about 10 over what i was actually doing (used my gps to get speed) and worked right again after i pulled off, turned the truck off, fired it back up and started driving again. Why would it do this? I know the gas guage on the truck is very sparatic too, it is all over the place and never reads the right amount. I wonder if there may be something bad behind the guage cluster, but i wouldnt know. Ive only had this truck for a week now so I dont know them well yet
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





do you hear a clicking noise from behind the gauge while at highway speeds? If so you may have a bad cable.
 






The speedometer is strictly mechanical. It is possible the cable is not fully seated in the back of the cluster.

On the gas gauge, does it jump around on a bump, or is it steady but wrong? The gas gauge is pretty basic. There's the sender in the tank, and the gauge, plus a little module that is supposed to prevent sudden changes, like... going over bumps.
 






my speedometer sometimes does that same thing..and its always done it (owned the truck since new).
 






Sometimes the VSS goes bad and it will not engage the speedo correctly. Takes all of 2 mins to remove it and inspect for any visual damage. Their could be internal damage to it that you will not see from just looking at it tho. Swapping it out with a known good VSS will help diagnose it.
 


















Its the thing near the end of the speedo cable down by the trans/transfer case. It has a couple wires on it that the computer uses. The Speedo is driven only by the cable itself.

If the cable if frayed, or the driven gear (the one on the end of the cable) has worn teeth it can make the speedo jump. When you have the driven gear out of the trans/transfer case, look at/feel the drive gear that is in the transmission/transfer case. If its really worn (convex) then that can cause the issue too (I've had that issue).

~Mark
 






Back
Top