Speedometer bounces. | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Speedometer bounces.

Sir Robin

Active Member
Joined
November 3, 1999
Messages
61
Reaction score
0
City, State
NY
Year, Model & Trim Level
'94 XLT
Starting at approx 50k miles, the speedometer needle started bouncing around at highway speeds. I used to be able to slap the dash to make it stop, but no more. Now, it bounces around pretty much at all speeds (worse at higher speeds). A Ford tech I met at a party said he's seen that on Tauruses, and they always replaced the speedo head unit.
Can the speedo unit be replaced independantly of the odometer? If so, I think I can do it myself.
If not, how do I go about this? I'm concerned about the odometer issue. Does a dealer have to do it so that the new odometer is certified? Will it start at zero, or can the numbers be turned to match the real miles? I want to avoid any appearance of impropriety.
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





Are you sure its the cluster?They have a coulple on ebay right now for cheap.I changed my cable and it stopped doing that
 






Actually, I'm not sure. The Ford tech seemed pretty sure, though.
I guess I can try the cable first. Even just wiggling/tightening it.
But i'd still like to know about the rest.
 






Cuold be bad gears in the cluster but Ive also seen worn/ frayed speedo cables do this.Good luck
 












Mine does the same thing...I have not brought it in yet to get checked out yet, but do you guys know if this is covered under the Ford extended service plan? If not, do you know how much it costs to get fixed?

Thanks.
 






I forgot to mention that there is a low buzzing noise coming from the cluster. Kind of sounds like the old speedminder buzzers on my dad's old Buicks, but not as loud.
Does the whole cluster have to be replaced as a unit? Or can the speedo itself be replaced?
 






its worn gears. like a clicking, buzzing?
 






more of a buzzing, than clicking.
 












Originally posted by Yaucco
Mine does the same thing...I have not brought it in yet to get checked out yet, but do you guys know if this is covered under the Ford extended service plan? If not, do you know how much it costs to get fixed?

Thanks.

Your 95 most likely is not a mechanical issue, but an electrical issue. the 95+ explorers do not have speedo cables they are electronic gauges. How bad does it bob up and down? Mine will sometimes do it slightly, but it hardly does it at all. It's nothing i would worry about in my case. I dunno how bad yours does it, but i think it should be covered under ford's warentree.
 






You know Travis, I think we've had this conversation before, I say something about the speedo cable and you remind me they're electronic. Oh well, I'll learn one of these days ;)
 






Well, Sir Robin has a 94 so your right, I was just letting Yucco know that the 95+ won;t have the cable and that it's a totally different issue...

Hows the 97 Limetid doing these days anyway?
 






Ha! I was right then ;)

Limited is running well, just had a whole ball joint fiasco, same one you did a while back. Can't track down that creak in the front end. How's your truck runnin?
 






Sir Robin,

Ours did the same thing and all Rick did to fix it was to replace the cable. Good Luck!
 






Originally posted by Stephen
Ha! I was right then ;)

Limited is running well, just had a whole ball joint fiasco, same one you did a while back. Can't track down that creak in the front end. How's your truck runnin?

My truck is running ok, but it's starting to have little "issues" more and more. Hopefully it stops soon. i had an electrical problem due to a water leak I had and then I had a front axle seal go out at the same time basically.....I'll be needing 2 ball joints this summer so I think I might just put 4 new MOOG joints on so I never have to mess with them again.. It's got 120,000 but still runs pretty good (sometimes it has that rough idle everyone has, but i got new fuel injectors waiting at home:D ....
 












Back
Top