Squealing noise front front end while in reverse | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Squealing noise front front end while in reverse

beanstump

New Member
Joined
February 11, 2024
Messages
2
Reaction score
0
City, State
Farmington, NM
Year, Model & Trim Level
04 Ford explr. 2wd 4.0 v6
Hi everyone, New to forum first post. I have a 2004 explorer 4.0 l v6. 2wd. I have a constant squeal when in reverse only coming from the front. I also have a clunk( just once) when coming to a stop at slow speed, forward and reverse. I have replaced both outer tierods, upper and lower ball joints, both hubs,rotators, New brakes, New tires, and alignment. Calibers seem to be fine. No in and out movement on inner tierods. Control arms and bushings look good. Sway arms look good. No pulling when driving. Do have a shake when on the highway and steering feels loose when turning right. Not sure what else to check without taking it to a shop. Not sure I want to fit that bill. Any suggestions?

Thought I would add that squealing does not change when brakes are applied.
 






Have you checked for worn or broken engine mounts/trans mount? Belts? Fan hitting shroud?

Is the noise low or high in the engine compartment? Left or right sided?
 






Fan
Have you checked for worn or broken engine mounts/trans mount? Belts? Fan hitting shroud?

Is the noise low or high in the engine compartment? Left or right sided?
Looks good. Belt and tensioner all look good. HRd to tell exactly where it's coming from. Will check engine/ Trans mounts. That would explain the clunk but would it make it squeal in reverse?
 






Not too likely, but not impossible. Squeals, moans, groans, clunks, and thunks are all parts of the joy of working on a vehicle.
 






Back
Top