Stalled today | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

Stalled today

Masterd

Well-Known Member
Joined
October 16, 2005
Messages
807
Reaction score
6
City, State
Upland, CA
Year, Model & Trim Level
1993 Explorer Sport
Eh, the Explorer stalled at a stoplight today. I freaked out when the oil pressure went to zero, but I realized it had stalled. It kinda lurched and quit. No check engine and it started right back up.

Do you guys know anything I could link this too?
 
<

Join the Elite Explorers $20 Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




Tbars4

Moderator Emeritus
Elite In Memoriam
Joined
March 4, 2007
Messages
26,366
Reaction score
69
City, State
anaheim hills,california
Year, Model & Trim Level
95 ranger 4x4/ 91 X 4x4
i myself would think fuel...i would find out how long it's been since the fuel filter was changed...10 bucks i believe...i am basing this on that you have had no other problems with all this heat we've had....
 
<



Masterd

Well-Known Member
Joined
October 16, 2005
Messages
807
Reaction score
6
City, State
Upland, CA
Year, Model & Trim Level
1993 Explorer Sport
Well the AC was on, but the temp gauge wasn't above half way. Oil level was good, as was the coolant level.

The fuel filter isn't that old either. It just sorta bucked and died. The most recent thing I did was replace the plugs and wires, and it ran fine after that, besides some surging that its been doing on acceleration.

It shudders on acceleration, mostly from 2000 - 2500 rpm and you can "hear" it. I haven't figured out what it is, but you can hear it at idle in the cab. Its a muted thumping style, intermittent sound. I think it corresponds to the ticking i hear outside, but Im not sure
 
<



Tbars4

Moderator Emeritus
Elite In Memoriam
Joined
March 4, 2007
Messages
26,366
Reaction score
69
City, State
anaheim hills,california
Year, Model & Trim Level
95 ranger 4x4/ 91 X 4x4
ticking??? thumping??? did i miss something??? have you taken a look at your wires...night time is good for this with your engine running...that ticking could be a wire arcing....also, i take it your rpm's have been fine???...i might think it as something else but if your check engine light comes on just briefly when you start the vehicle and goes off, it rules out an error code...if that light does not come on briefly, you might have a burnt bulb and have error codes that need to be read...
 
<



Masterd

Well-Known Member
Joined
October 16, 2005
Messages
807
Reaction score
6
City, State
Upland, CA
Year, Model & Trim Level
1993 Explorer Sport
The wires look good, not touching and not arcing. I replaced them not just 4 weeks ago.

Check engine light also verified working.

As far as RPMs go...it idles right at 500. Always has. The idle is smooth when in D or any moving gear, but kind of rough when in P.

I started noticing the surging after plugs and wires.

As for the thumping / knocking noise, you can hear it at idle. Kind of like.... thump.....thump thump thump....thump..thump.....thump.

Theres the vibe / shudder at 2500 rpm....
 
<



Tbars4

Moderator Emeritus
Elite In Memoriam
Joined
March 4, 2007
Messages
26,366
Reaction score
69
City, State
anaheim hills,california
Year, Model & Trim Level
95 ranger 4x4/ 91 X 4x4
either something is clogged, dirty, or starved...normal rpm at idle is 600-800, there is some variance but when you get smogged thats the first thing they check, idle rpm...the normal ticking you might be hearing would come from your egr...if that was a problem you would have gotten an error code...
have you cleaned your iac, tps, and throttle body??? those tend to have the same decriptive trouble as you are mentioning...they would create a variable rpm and not always throw a code...whats got me stumped is the thumping...while you are cleaning these items i would also look at your vacuum connections...i myself would take and go to autozone and get my codes read for free anyway...even though you don't have a light on, you will have stored trouble codes which might shed some light...
 
<



Masterd

Well-Known Member
Joined
October 16, 2005
Messages
807
Reaction score
6
City, State
Upland, CA
Year, Model & Trim Level
1993 Explorer Sport
Well usually it runs great besides the annoying thump.

Could a rocker arm / lifter be heard as a thump inside the cab. From what I hear it could be a main bearing, but im hoping not. Above 2500 rpm it sings. At 2500 rpm it vibrates alot, and below I get that intermittent noise.

Vacuum tree looks good, no missing hoses or caps. The only thing ive cleaned is the maf with some CFC cleaner, and I may have noticed a 1-2 mpg increase, but nothing more.
 
<



Top