Stuck A/C high side Schrader valve | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! Once registered you can join the Elite Explorers to eliminate ads from the website.

Stuck A/C high side Schrader valve

al bundy

Member
Joined
September 13, 2003
Messages
11
Reaction score
0
City, State
ILL
Year, Model & Trim Level
2003 XLT V8 AWD
Been having a slow leak losing about 10-12oz/year the last 2 years. Normally I just top it off, but with 134a doubling this last year, figured it's time to fix it. I found high side Schrader valve was leaking. I was going to replace both while the system was open, but after getting the low side loose, I tried to loosen the high side and it was stuck. I broke one removal tool, and bent another trying to get it loose. I even tried using a needle nose pliers it still wouldn't budge.

Anyone have any ideas on how to get it out? This is on a 2003 explorer... original factory 19 year old valves
 



Join the Elite Explorers $20 Get rid of the ads!
Elite Explorer members see no advertisements, no banner ads, no double underlined links.
Add an avatar, upload photo attachments, and more!
. First register on the forum, then join the Elite Explorers to get rid of the ads!





Fix4Dirt

Get a Load O' This Guy!
Elite Explorer
Joined
December 22, 2021
Messages
1,689
Reaction score
630
City, State
Los Angeles, CA
Year, Model & Trim Level
1998 XLT 4x4
if my understanding is accurate 134a is corrosive, so maybe try using some fridge oil on the valve core and try heating it lightly, then try to work it off. other than that, not too sure!
 






al bundy

Member
Joined
September 13, 2003
Messages
11
Reaction score
0
City, State
ILL
Year, Model & Trim Level
2003 XLT V8 AWD
Thanks. I'll give it a try tomorrow.

Are you talking just a heat gun on the fitting?
 






Fix4Dirt

Get a Load O' This Guy!
Elite Explorer
Joined
December 22, 2021
Messages
1,689
Reaction score
630
City, State
Los Angeles, CA
Year, Model & Trim Level
1998 XLT 4x4
probably? i wouldnt start off with the torch, unless it comes down to it...
 






al bundy

Member
Joined
September 13, 2003
Messages
11
Reaction score
0
City, State
ILL
Year, Model & Trim Level
2003 XLT V8 AWD
Thought I was going to break my needle nose, but it finally came out! I heard a snap and thought it was my pliers breaking, but it finally came loose.

Now pulling a vacuum again. No leak after pulling vac earlier today, so it had to be those schraders leaking. I should be adding 134 tomorrow (crossing fingers). I'll find out for sure next year when it's AC time again if that was it.
 






Fix4Dirt

Get a Load O' This Guy!
Elite Explorer
Joined
December 22, 2021
Messages
1,689
Reaction score
630
City, State
Los Angeles, CA
Year, Model & Trim Level
1998 XLT 4x4
Thought I was going to break my needle nose, but it finally came out! I heard a snap and thought it was my pliers breaking, but it finally came loose.

Now pulling a vacuum again. No leak after pulling vac earlier today, so it had to be those schraders leaking. I should be adding 134 tomorrow (crossing fingers). I'll find out for sure next year when it's AC time again if that was it.
alright! glad it all worked out!!!! :bounce:
 






Top