Stumbling with electrical problems. | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

Stumbling with electrical problems.

Reynolds2x

New Member
Joined
March 11, 2010
Messages
3
Reaction score
0
City, State
Sandusky, Ohio
Year, Model & Trim Level
2002 Eddie Bauer 4x4
Hi all,

I have a 2002 Ford Explorer Edie Bauer, 80,000 miles or so. Recently the check engine light came on. I have noticed that when I have almost come to a complete stop, the engine almost dies :mad: and the surges back up to idle. Sometimes this happens twice on the same stop. Also, the exhaust smells unusually toxic and my gas milage has dropped about 3 miles per gallon.:thumbdwn:

On a side note, the keyless entry has not been working recently, nor have the lock / unlock buttons on the door, and the radio does not shut off when the door is opened.

Any ideas on what might be causing these issues?

Thanks!:D
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





BrooklynBay

Moderator & long time member.
Staff member
Moderator
Elite Explorer
Joined
November 11, 2005
Messages
56,110
Reaction score
1,031
City, State
Brooklyn, NY
Year, Model & Trim Level
88 89 93 95 96 Aerostars






Cobra Jet

Well-Known Member
Joined
April 11, 2006
Messages
152
Reaction score
14
City, State
Southern, NJ
Year, Model & Trim Level
2004 XLS
If you have a local AutoZone near you, they will extract any engine light codes free of charge. I'd suggest going there, let them pull the codes and tell you what the possible issue may be... at that point, you will then have the exact codes and you can update your thread here, and some of us can then point you in the proper "fix" direction (especially if you can fix at home to save $$$ over Dealer or shop costs).

Stalling or intermittent idle/drivability issues could be a number of things. If you are getting a strong gas odor, I'd suggest checking into emissions components such as O2 sensors, EGR, EVAP canister purge sensors, vacuum lines, engine coolant temp sensor, etc. However, without knowing the codes, you'd be throwing $$$ & parts at the vehicle, rather than fixing the correct part initially.
 






swetrid

Explorer Addict
Joined
September 30, 2010
Messages
1,888
Reaction score
7
City, State
Reading Pa
Year, Model & Trim Level
1999 Eddie Bauer
What codes? Sounds like a vacuum leak, ck over all the pcv hoses because they rot out or collapse.
 






BigRondo

USMC 1371
Staff member
Moderator
Elite Explorer
Joined
February 15, 2010
Messages
7,845
Reaction score
17
City, State
Charlestown, RI
Year, Model & Trim Level
2014 Escape SE
On a side note, the keyless entry has not been working recently, nor have the lock / unlock buttons on the door, and the radio does not shut off when the door is opened.

Any ideas on what might be causing these issues?

Thanks!:D

Welcome to the forum! :salute:

I had similar electrical issues with my 02 xlt. The dome lights would stay on until the battery saver feature turned them off, the driver side puddle light didn't work, the keypad on the door would set off the alarm when I pressed it, the door ajar light would flash and beep at highway speeds, etc.

A lot of electrical issues can be traced back to broken/damaged wire(s) in the boot between the body and the driver's door. I found a broken wire and repaired it and all is back to normal!

Could also be related to the door ajar switch.

Here is a great thread for removing the door panel and checking/replacing the door ajar switch, thanks to borland for the awesome write-up: http://www.explorerforum.com/forums/showthread.php?t=249253

That is a great write up.

On a side note, before going through a complete replacement of the switch, you can spray WD40 into the door latch opening on each door, as these become stuck sometimes....and this can alleviate the issue.

This worked for me, after going for more than a year of the "door ajar" light coming on occasionally...mainly after a car wash, high humidity, or rain....making me unable to lock/arm the vehicle from the door keypad and keeping the dome lights on. Worth a try....it worked for me :thumbsup:

Here is a great thread for checking for broken/damaged wires, thanks to synyster for this awesome write-up: http://www.explorerforum.com/forums//showthread.php?t=270081

Hope this helps out. :D
 






Top