supercharged 5.0 true fire 98 explorer sport | Page 171 | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

supercharged 5.0 true fire 98 explorer sport

hi everyone, my name is tim . i live in selkirk, manitoba, canada and as if this date that i am posting this, i am 36 years old.

i bought my sport in jan 05 from a local ford dealer. it had 111,000KM's on it. this is the second sport i have owned. it was sitting on the lot for about 8 months before i came along. i am the third owner (i was able to track down the person that traded it in, and they got it from a friend, who bought it new in 98).

i started to do a few things to it after i first got it, then i found this site, and all hell broke lose! i've never been satisfied with something the everyone else has, so i started to tinker with it even more.

19_Medium_.jpg


15540626_10154060266577513_2405619719549828739_o.jpg


14242313_10153799452207513_5208987697549996496_o.jpg


50213558658671_547488670_7421875_7068292_n_Medium_.jpg




15_Medium_.jpg



evil_and_min_evil.jpg


DSC01337_Medium_.jpg


DSC01341_Medium_.jpg



DSC02874_Medium_.jpg


10660988_10152352316047513_1588917598_n.jpg


m122b.jpg


981349_256309931177894_674155846_o_1_Medium_.jpg



DSC04422_Medium_.jpg


mods include

interior

installed factory tilt, cruise, overhead console, auto dimming mirror, full length console, with a message center (it didn't have these from factory).

white face with blue flames indigo gauge covers (they light up blue)
blue l.e.d. everything
white l.e.d. interior lights
Kenwood DDX392 Touch Screen Head Unit
alpine 4 channel amp (all four speakers)
boston acoustic front and rear speakers
alpine mono amp (for sub)
2 12 inch jl audio subs
rockford fosgate cap
passenger side one touch window down mod.
custom transfer case shifter
tripple a pillar gauge pod, housing autometer boost, Innovate LC-1 wideband, and oil pressure gauge
12v power inverter with 120v plug in a 2 usb plugs built into the center console

exterior

BMW E46 projectors, mounted into stock housings using clear lens
6000K HID head lights
angel eye "driving" lights, with 8000k h.i.d.'s
clear parking/corner lights
billet grill (powder coated by Turdle)
blacked out ford emblems
custom front steel 95-98 bumper, with 4 inch round tubes welded in for driving lights
shaved radio antenna
shaved roof rack
black euro tall lights
l.e.d. license plate lights
smoked out 3rd break light
lund rear tailgate spoiler/wing (formally from the truck "blackjack" owned by EF member Spas)
hand made roll pan (made from 3 1/2 rear bumpers, with 1/4 inch diamond plate on the top, and it is removable)
aluminum T/A differential griddle/cover (powder coated by Turdle)
Motegi Mr107 20' rims
goodyear wrangler hp p245/50 r20
1 1/4 wheel spacer in the rear, 3/8 in front
and most noticeable, black with blue pearl paint, and blue true fire (ground effects are black with blue pearl as well)

Suspension

2 inch lowering blocks in the rear, reverse TT in the front (2 inch as well)
Explorer Express rear sway bar
4 door leaf springs
rancho rs9000 adjustable rear shocks
03-05 sport trac spindles with drilled and slotted rotors

performance

5L swap
347 stroker
TFS twisted wedge alum heads
comp gold 1.6 rockers
comp cams CCA-35-556-8 nitro cam
heavily modified edelbrock victor jr air gap intake (which serves as a valley pan now)
eaton m122 supercharger (metco 2.70 pulley, and ASP 8 rib 7 1/4 crank pulley) with custom made mount with bell intercooler core
8 rib serpentine belt conversion using pulleys from a 7.3 powerstroke
custom made 3 1/2 inch throttle body elbow
accufab 75mm throttle body
4 inch intake pipe
PMASS MH90 90mm Universal 3000 KG/HR MAF
amsoil cone filter
F.A.S.T. 60lb injectors
edelbrock fuel rails, trick flow specialties fuel pressure regulator with summit racing fuel pressure gauge
walbro 255lph fuel pump
1/2 inch steel braided fuel pressure line from tank to rail using 8AN fittings
torque monster headers
2 1/2 duel pipes with flowpro duel in and out 2 1/2 single muffler
accel extreme 9000 ceramic 45 degree plug wires with boot protectors
4R70W w/2600 stall with J mod
tuff stuff 200a alternator
tuning made possible with sct pro-racer package, and tuned with major help from member [MENTION=102869]Dono[/MENTION] and [MENTION=81804]4pointslow[/MENTION]
flex a lite duel 12 inch electric fans
big 3 upgrade (4 gauge wires)
meziere innercooler water pump
2 froozenboost innercooler rads

Transfer case

4406 manual shift from a 97 F150
modified stock trans cross member to accept 93 mustang 5L polyurethane tans mount
double cardan rear drive shaft

because of all the "fun" i had doing the bodywork, and some other things to my truck, i have nick named it "evil dora" or if you like, just plane "evil"!
and now the thank yous

my buddy gord leiss, who let this thing sit in his garage for 3 months while i did the body work to it. he also gave me a hand with some of the prep work, and painted it for me

kevin willson for doing the true fire http://affordableairbrushing.ca/

Joe Bukoski for letting me do the 5L/4406 swap in his garage

now people from this site, weather they knew it or not, they helped

BIG THANKS to tara a.k.a. explorersport77 for pictures of her truck. wouldn't been able to build the roll pan with out them!

ExplorerSport77's X "Hotness"

jon a.k.a. Turdle for selling me some real swanky rear shackles, as well as powder coating the diff cover and sending them up to canada. as well as much needed info on v8, and 4406 swaps as well as doing the grill and showing me how its done.

don aka dono for the help with the tuning, and wideband, as well as the supercharger

andy aka ahodges for some parts, and any help i needed for all the go faster goodies

5.0 swap - w/ 4406

jad2411 for finding me a link for my hidden antenna

ryan a.k.a. MustangP51 for doing his write up on making l.e.d.'s for interior lights, and how to make projectors

P51's HID Headlight (Projector) and Fog Conversion (PICS)

and N3ELZ cardomain page for L.E.D. switch and cruise pod mods

http://www.cardomain.com/ride/296394/2002-ford-ranger-regular-cab/page-6
http://www.cardomain.com/ride/296394/2002-ford-ranger-regular-cab/page-12
http://www.cardomain.com/ride/296394/2002-ford-ranger-regular-cab/page-23

bob a.k.a. rwenzing for showing me speedhut's sit for the gauges

Gauges, Custom Gauges, Tachometers, Speedometers, Shift Light, Pod

Buzz4x4 for his write up on blacking out ford emblems

How to Make Your Own Custom Ford Emblems

the late aldive for his write up on one touch down passengers window mod

http://www.explorerforum.com/forums/showthread.php?t=141027&highlight=touch+passengers+window+mod

BIG COUNTRY, for his write up on how to install a auto dimming mirror

http://www.explorerforum.com/forums/showthread.php?s=&threadid=84968

BIG COUNTRY, 98formulaLS1, and Ryon40 for there write ups on how to install a message center

http://www.explorerforum.com/forums/showthread.php?t=225017&highlight=BIG+COUNTRY
http://www.explorerforum.com/forums/showthread.php?t=80670&highlight=message+center
http://www.explorerforum.com/forums/showthread.php?t=245085&highlight=Ryon40

MountaineerGreen for his 4406 swap write up and "Custom" Driveshaft for a 4406 and 4" Superlift on the Cheap " (even tho its lowered

http://www.explorerforum.com/forums/showthread.php?t=166726&highlight=awd+4x4+swap
http://www.explorerforum.com/forums/showthread.php?t=185232

Simon, aka blueka for his "pickle" thread, and help anytime i picked the phone up the phone on the 5L swap

http://www.explorerforum.com/forums/showthread.php?t=271813

Jon, aka 4pointslow for any MAJOR technical advice i have needed

http://www.explorerforum.com/forums/showthread.php?t=219092

i wish i could find who did the write up on the overhead console install, but here is the link

http://www.explorer4x4.com/overhead.htm

Russ aka NICE59FORDF100 for his help on the wiring, and what to watch out for electronically.

hopefully one day, i will be able to help people on here just as much as the people that i have mentioned above!

picture.php

plus you know you have done something right when.....

your truck (as well as corkey) wins truck of the month

http://www.explorerforum.com/forums//showthread.php?t=296023

is the feature truck on the fun hump day radio show (starts roughly around the 30 min mark)

http://explorerforum.podbean.com/2011/03/23/19-vroom-zoomboom/

and you drive 26 hours ONE WAY to the carlisle all ford nationals in june 2010 and 2011, and grab second place in the s.u.v. all category!

scan00012.jpg


then in 2014 you go back to the same show you have been to 5 years in a row (nothing by most, but its one hell of a long drive) and take first!

scan00014.jpg
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





took it for a lap around town last night. still is loading up on fuel when it sits idling when you go from a cold start. that will be dealt with in tuning hopefully. its also down on boost. when the blower was off the rotors looked a little beaten up. might have to replace the entire head unit. not great. however, if i do end up doing that, this one might get sent to Stiegemeier Porting Services. the wallet will tell in time. for the high idle, i smoked the motor today, and i mean i left it on for 30 or more mins. nothing. will have to look and see what the idle was set to.
also didnt think it was going to be, but that hood or for me at least is a distraction lol. guess i will have to get used to it. other then that might play with a few small things over the weekend. my tune session is on tuesday. hopefully can make some ground.
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





its progress! After your tune, I'm interested to see what the boost numbers are.
 






its progress! After your tune, I'm interested to see what the boost numbers are.
not sure if they will change, could be wrong (hope i'm wrong) guess we will have to see.
 






today was the tune day...that didnt start off so great.
as i was waiting for marty to call, my stereo died. not a big deal, but i needed my bluetooth to hear them. then they were late with another customer. so after that, i had told them we need to take some fuel away from the cold start because it was fouling plugs bad. that was done, and a few other small things. started it up, and it was a big time difference. started driving then my laptop decided this was a good time to want to update itself (!!!).
while it was doing that, we decided to give it another go later when my laptop was done. snuck over to a buddys place for him to check the stereo for me. somehow my amp left the chat (second alpine in 2 weeks, the one in my ranger also gave up on me).
back to tuning, as i was doing the drive around, jeff had mentioned that i need to get a innercooler. i said i had one. he mentioned i need to get some fans on the rads, or see why its running high IAT's. that has bugged me for a while now. then the drive down the highway. i gun'd it a few times, then all of the sudden it got real loud! i found one of my band clamps slid back a bit opening one pipe up before the muffler (running strait pipped). after i figured out that, they both where happy with what they saw on the tune and how it is running. so now she is tuned. might head in tomorrow for sunday night cruise depending on the weather and what kind of time i have!

448020707_10159530049342513_2261920636245696459_n.jpg
 






while working on a truck i have here today, i hear someone knocking at my gate. i go to look and find one of my friends that was living in british columbia for the past 2 years had moved back. while he was their he bought a 16 challanger.
"well, hell now it looks like i will be going in for cruise night now!" i said to him. first one in over 2 years. i gotta say, evil ran great! no problems what so ever. this is also the furthest i have drove it in a long time (only 100kms, or 60 miles round trip, but you gotta start someplace). it was around 18C or around 65F, and i was watching my IAT's. they got up there. at one point hit 199F, but would drop when i started driving. when i came home, i saw that they were around 145F. now you would think that with it being that hot, the rads should be to. i put my hand on the lower innercooler rad, and it was cold. like outside temp cold.
this makes me scratch my head. any ideas anyone?
 






The temperature sensor is reading the exhaust temperature of the blower the act of compressing air creates high temps it doesn't matter what temperature the engine block is when 200 plus ° are coming out of the blower

I hope that explains it

I was having the same temperature problems as you until I got the methanol location worked out Now it never goes above 140 on the highest end Normally about 118 under boost with the meth kicking
 






I Am super Glad you are driving it and she Is running and working well!
 






The temperature sensor is reading the exhaust temperature of the blower the act of compressing air creates high temps it doesn't matter what temperature the engine block is when 200 plus ° are coming out of the blower

I hope that explains it

I was having the same temperature problems as you until I got the methanol location worked out Now it never goes above 140 on the highest end Normally about 118 under boost with the meth kicking

i totally get your explanation, and yes the sensor is under the blower.....kinda. the innercooler is below the blower, then then the sensor. thats what i dont get (unless i missed something you explained). it should be reading the temperate after the innercooler.
i had also asked the tuners if i should put a meth kit in, and where however they both said i need to sort this problem out first which i also understand. the meth kit wont kick on unless im on the throttle and wont help for regular driving.

I Am super Glad you are driving it and she Is running and working well!

you have no idea lol! it feels strange driving it because its been so long. i do have bugs to work out, but as of this moment, they are not serious ones that will keep me from driving it. reverse lights, and getting the ac to work will be the first ones. then cleaning up the harnesses will be after that.
have a friend here that did a terminator x i will say 5 or more years back in a ranger. when he saw it last night he was baffled that i no longer had the ford ecm in it because he thought you needed it, and still ran his. he is now going to rip his out so he can clean up his wiring as well.
 






Sounds like the inner cooler pump isn't pumping fast enough to move the fluid around
Maybe time for a fan
 






Sounds like the inner cooler pump isn't pumping fast enough to move the fluid around
Maybe time for a fan

lucky for me i have a new spare! wish i could find out how many gmps it is or isnt pumping.
 






Hahahaha what functions would the factory pcm Still Perform?? Probably thought it was needed for the starter and pats… crazy. Rip that pos out of there!
 


















Insert bfh and sawzall emojis maybe torch emoji too
lol
 






Just what exactly are your IAT's at the end of a wot pull?
Can you remember at all what they were before the intercooler was added?

That intercooler brick should be reaonably efficient. It's not a crappy knock off.
I wonder whats wrong.
Pump? - possibly
design issue? -doubtful. You and the guy that made the brick fit undersand how air flows pretty well.
IAT location issue? maybe.

Somethings up. No idea what though.
 






Just what exactly are your IAT's at the end of a wot pull?
Can you remember at all what they were before the intercooler was added?

That intercooler brick should be reaonably efficient. It's not a crappy knock off.
I wonder whats wrong.
Pump? - possibly
design issue? -doubtful. You and the guy that made the brick fit undersand how air flows pretty well.
IAT location issue? maybe.

Somethings up. No idea what though.

after a wot, around 150ish i believe. i couldnt see what they were before with the old m112, or when i first put the m122 on. you would actually know better then me lol.
pump, maybe. it was used after all and i dont remember how many hours were on it. not sure if its weak or not.
design, anything is possible. i called the guy who welded the innercooler in, he said is was a small cooler (i didnt think it was). i had also mentioned to him bell rates it to upwards of 600-700 hp, and i dont think i am there.
IAT, i am now going to rule that one out. with the cowl hood, and the location of that sensor, any hot air can escape now, or so i think at least.
when your old pump died on you don, what did it do. just stop working, or you knew it was time to get it rebuilt. i might try swapping in the new pump i have and see what it does.
 






after a wot, around 150ish i believe. i couldnt see what they were before with the old m112, or when i first put the m122 on. you would actually know better then me lol.
pump, maybe. it was used after all and i dont remember how many hours were on it. not sure if its weak or not.
design, anything is possible. i called the guy who welded the innercooler in, he said is was a small cooler (i didnt think it was). i had also mentioned to him bell rates it to upwards of 600-700 hp, and i dont think i am there.
IAT, i am now going to rule that one out. with the cowl hood, and the location of that sensor, any hot air can escape now, or so i think at least.
when your old pump died on you don, what did it do. just stop working, or you knew it was time to get it rebuilt. i might try swapping in the new pump i have and see what it does.
150 at the end of a wot run isn't bad at all. Lower is obviously better.
When my pump failed, it became very noisy. It was also for me to open a cap and visually see the flow.
On our positive displacement blowers, they recycle the heated air at low rpms which just keeps heating the already heated air. Not ideal. Yours are still high at idle though.
I had to do a laptop change, so I don't think I have any of your old logs. I'll look for them when I get back home this weekend.

Hows the loading up with fuel and fouling the plugs at idle? Honestly that one had me worried.
 






150 at the end of a wot run isn't bad at all. Lower is obviously better.
When my pump failed, it became very noisy. It was also for me to open a cap and visually see the flow.
On our positive displacement blowers, they recycle the heated air at low rpms which just keeps heating the already heated air. Not ideal. Yours are still high at idle though.
I had to do a laptop change, so I don't think I have any of your old logs. I'll look for them when I get back home this weekend.

Hows the loading up with fuel and fouling the plugs at idle? Honestly that one had me worried.

well the pump i have now was noisy right from day one. i know if i open the cap for the innercooler, it will spray all over the place.
i might have some old logs on my laptop, but i dont know how far back they go.
they corrected the fouling on the last session of tuning. i asked them to take fuel away from the cold start, which they did. i could notice a big difference right when i tuned the key. way happier now!
 









Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





Maybe you can have a listen to my pump at some point (I think we have the same pump WP136 ?) Electric Pump Remote, 20 GPM Inline, Single in-single out
thats what the new one is. not sure how busy you are on fathers day, maybe ill drop by when i go to the parental units.

i did however run into a problem with the pumps, because nothing comes easy.

new pump.

447638049_824122902579792_1443315940532571257_n.jpg


pump thats in the truck.

61502321_354095235251124_6326815168667844608_n.jpg


118673724_818462575361581_4851636967361748505_n.jpg


the inlet and outlet are in different spots. :banghead:looks like i will have to either get creative with my hoses, or outright redo them which i really dont want to do.
 






Back
Top