Sync Update gone wrong | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

Sync Update gone wrong

Talon747

Elite Explorer
Joined
March 11, 2018
Messages
12
Reaction score
7
Year, Model & Trim Level
2011 Explorer, Limited
I got a message in my Ford owner home saying that that Sync2 -v3.10 update is available. So followed the instructions and did the update as instructed. 40 Mins later just a blank screen my touch screen is blank. No screen at all. Any suggestions please? Everything was working perfectly well before the udpate
 






peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
34,789
Reaction score
3,368
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
Welcome to the Forum.:wave:
When did you complete the update? Did you get the message Update Successful or Complete or something similar? I completed an update once but the screen showed I was still on the previous version. After turning the vehicle off and back on a little later, the updated version showed.

Peter
 






Talon747

Elite Explorer
Joined
March 11, 2018
Messages
12
Reaction score
7
Year, Model & Trim Level
2011 Explorer, Limited
Welcome to the Forum.:wave:
When did you complete the update? Did you get the message Update Successful or Complete or something similar? I completed an update once but the screen showed I was still on the previous version. After turning the vehicle off and back on a little later, the updated version showed.

Peter
Thanks for the reply, IT went into blank screen mode after the first reboot and didn't do anything for over 40 mins.

Anyway I am sorted now, After bit of a panic and kicking myself for doing starting the update, I remembered I had the ford app on my phone that connects via Bluetooth dongle on ODB port. Went in and did a module rest and that seem to kick off the update again and then started to copy the files from the USB.... Phew, thought I bricked it.
 






Top