Thermostat housing leaking | Page 2 | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

Thermostat housing leaking

swshawaii

Elite Explorer
Joined
April 3, 2009
Messages
9,625
Reaction score
567
City, State
Kailua-Oahu, Hawaii
Year, Model & Trim Level
'05 Sport Trac XLS (RWD)
In order for the ECT sensor and gauge sender to function properly, they must sit flush on the housing.
Can you remove the brass threaded insert from the old sensor to compare threads? What part numbers?
 
<

Join the Elite Explorers $20 Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




gnx547

Well-Known Member
Joined
September 29, 2011
Messages
109
Reaction score
1
Year, Model & Trim Level
1995 GT
I looked at the factory one and the sensor is a little higher. I got everything installed, now I having issues with the coolant. The radiator is filled up with coolant and when the car is running a lot of the coolant is pouring out?? I know there will be some air but the coolant is rushing out? Why wont the coolant stay in the radiator? What is causing this to happen? Any ideas?
 
<



swshawaii

Elite Explorer
Joined
April 3, 2009
Messages
9,625
Reaction score
567
City, State
Kailua-Oahu, Hawaii
Year, Model & Trim Level
'05 Sport Trac XLS (RWD)
You have AIR in the cooling system because of your repair. Search "coolant flush", there are MANY posts.
 
<



PAExplorerXLT

Well-Known Member
Joined
October 14, 2014
Messages
263
Reaction score
0
City, State
Montgomery County, PA
Year, Model & Trim Level
1998 XLT 4.0 SOHC AWD
Isn't the air eventually purged in closed systems? Are there bleed nipples anywhere?
 
<



gnx547

Well-Known Member
Joined
September 29, 2011
Messages
109
Reaction score
1
Year, Model & Trim Level
1995 GT
No there are no bleeder nipples. I finally got the air out and no more coolant pouring out and no more leaks.

Now I notice the coolant temp gauge is not working. I did replace both sensors on the housing. Which coolant sensor is for the gauge? Is it the red connector?
 
<



<



gnx547

Well-Known Member
Joined
September 29, 2011
Messages
109
Reaction score
1
Year, Model & Trim Level
1995 GT
These are the sensors I bought from Oreillys. The gauge did work before. The gauge needle sits past cool. When I turn on the key the gauge needle slightly moves but not much.

BWD part# WT5053 for the temp sensor

BWD part# WT724 Sender for the gauge
 
<



gnx547

Well-Known Member
Joined
September 29, 2011
Messages
109
Reaction score
1
Year, Model & Trim Level
1995 GT
Could it be that using teflon paste caused the sensor not to have a good ground?
 
<



<



<



Top