Trans leak on side by shift linkage | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Trans leak on side by shift linkage

joebroni99

Active Member
Joined
October 20, 2008
Messages
62
Reaction score
0
City, State
Jersey
Year, Model & Trim Level
97 AWD 5.0
Hi Guys,

My 02 Explorer is leaking trans fluid. I don't really see where it is coming from. It appears to be on the side by the shift linkage. Is there a seal or something that goes into that which could be leaking? I am planning on dropping the pan tomorrow to see what is going on. But I am stuck on what to do to stop this leak as I don't see anything that would be leaking. The leak seams to be pretty bad of a leak as I believe the tranny is very low on fluid.

Thanks for anyones help or advice on this!

Joey
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





Most common would be the band adjuster lock nuts, possibly the linkage or bulkhead connector. YMMV
 






Does the linkage or bulkhead have some type of seal on it that can be replaced?
 






Does the linkage or bulkhead have some type of seal on it that can be replaced?

Yes, the linkage armature has a standard seal, will require some teardown to replace. The electrical bulkhead connector has an o-ring, and some folks like to use RTV on it as assurance.
 






Did some tear-down today. I found the leak, its the shift shaft seal. I hopefully ordered the right part. I think it is National 330385 Oil Seal. Will uodate tomorrow if I get the seal and it is right and hopefully the assembly will go smooth.
 






Back
Top