• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^

Trans Problem?

jar2187

Well-Known Member
Joined
November 13, 2002
Messages
321
Reaction score
0
City, State
Rhode Island
Year, Model & Trim Level
92 EB, 96 limited
While going about 45 mph, and then I get off of the gas completely the rpms drop from about 2000 just to 1500, and stays there until the truck starts to slow down to 35 mph and then from there the rpms and speed drop together until I come to a complete stop. Is this normal? I dont remember if it did this before.
I should also mention that sometimes when I put it into gear that the battery gauge goes down and so does the rpms. It almost feels like it is going to stall but it doesnt. What is causeing this?
When accelerating between 2000 rpms and 3000 rpms I get this werid rattling noise almost like metal flying around in a can or someting, is this pinging?
 




MrShorty

Explorer Addict
Joined
December 27, 2001
Messages
5,078
Reaction score
16
City, State
Spanish Fork, UT
Year, Model & Trim Level
92 XLT and '87 Bronco II
If it's an automatic transmission, then the RPM vs. vehicle speed behavior is normal.
The first thing I'd check is the IAC valve for the stalling when put in gear. It can get dirty which doesn't allow for free flow of air through the valve.
That is usually how "pinging" or spark knock is described.
 




jar2187

Well-Known Member
Joined
November 13, 2002
Messages
321
Reaction score
0
City, State
Rhode Island
Year, Model & Trim Level
92 EB, 96 limited
I just cleaned it a few weeks ago
 




Top