Trouble Code 157 MAF | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

Trouble Code 157 MAF

Harry P

Member
Joined
April 2, 2002
Messages
18
Reaction score
0
City, State
Harleysville, PA
Year, Model & Trim Level
94 XLT 4x4
CEL came on last week, and idle became rough.

KOEO: Code 111 (No faults on KOEO). I only get one CM Code 157 (Mass Air Flow signal is/was low or grounded – MAF). No other codes.

I took it out. It appeared fine, not dirty. I cleaned it with spray solvent. Put it back in, no change. I still get CEL and rough idle, and no additional codes.

Ex has 177k miles and the MAF has never been replaced. I recall taking it out to clean it six or seven years ago to solve the same code then.

What’s the next step? Should I buy a new MAF?

Thanks, Harry
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





BrooklynBay

Moderator & long time member.
Staff member
Moderator
Elite Explorer
Joined
November 11, 2005
Messages
55,897
Reaction score
962
City, State
Brooklyn, NY
Year, Model & Trim Level
88 89 93 95 96 Aerostars
Get a can of Mass Air Flow cleaner.
41fX171WA3L._SS500_.jpg
 






Harry P

Member
Joined
April 2, 2002
Messages
18
Reaction score
0
City, State
Harleysville, PA
Year, Model & Trim Level
94 XLT 4x4
Yep. I cleaned it. What's the next logical step?
 






BrooklynBay

Moderator & long time member.
Staff member
Moderator
Elite Explorer
Joined
November 11, 2005
Messages
55,897
Reaction score
962
City, State
Brooklyn, NY
Year, Model & Trim Level
88 89 93 95 96 Aerostars






2000StreetRod

Staff member
Moderator
Joined
May 26, 2009
Messages
10,600
Reaction score
294
City, State
Greenville, SC
Year, Model & Trim Level
00 Sport FI, 03 Ltd V8
check the output voltage

You can test the MAF sensor (MAFS) by backprobing the connector pins with straight pins and then measuring the outputs with a voltmeter at various engine speeds. From the code you can't tell if the MAFS output is low at idle or fast engine speeds. If the output is low at idle then your engine will run lean.
 






Top