Troubleshooting Fuel System | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership! If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

Troubleshooting Fuel System

cusingeorge

Member
Joined
December 23, 2008
Messages
12
Reaction score
0
City, State
Calumet, Oklahoma
Year, Model & Trim Level
97 Sport and 07 Limited
My 1997 4.0 SOHC 4X4 Sport Automatic (140,000 miles) misfired and the CEL came on. I drove it to Autozone and they put a code reader on and it gave these codes:

PO171

PO0300

Mileage went from ~19-20 to 11.5 mpg.

I can't really tell that it has lost any performance.

This started in Ocotober of 2007, since then I have had the injectors cleaned, replaced the plugs, wires, all the 02 sensors, air filter, fuel filter (2X), and have ran at least 2 cans of BG through it. I change the oil every 3000 miles and use a Motorcraft filter (FL1A) and Valvoline 5W30.

It has new Yokohama tires and all are at 32 psi.

I recently replaced the water pump, and thus all the coolant.

The brakes aren't dragging.

Here's what I'm thinking, please add or detract from this list:

1) Check my RPM's at 70 MPH (should be ~2200?)

2) Clean TB

3) Change Fuel Filter (again)

4) Clean MAF

5) Use SeaFoam instead of BG

6) Check the Fuel Pressure Regulator for leaks

7) Check the coolant temperature switch

8) Replace the catalytic converters

9) Replace the tranny fluid

I have heard about ethanol-based fuel breaking loose stuff that regular unleaded has deposited in the tank and lines, could this be the culprit?

Other ideas?
 


Holiday Special! Join the Elite Explorers $20 for 2 years! Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




gmanpaint

It's Always Something!
Staff member
Moderator
Elite Explorer
Joined
August 1, 2008
Messages
11,549
Reaction score
1,706
City, State
MO MO
Year, Model & Trim Level
94 & 95 XLT's
I would really like to hear what your problem turns out to be! I am going through some similar problems. I replaced a lot of items as well, and am steering towards the fuel pump going bad and not giving enough pressure. Mine has a bad stutter, feels like a misfire. Runs terrible at idle, will even die out, it will stay running when you give it gas, but you can feel the misfire/rough running engine. Cel spits out 02, & EGR codes, bank 1 & 2 lean. It has pressure in the fuel system, but I hear it might not be enough pressure. It is a pita to change the pump, so if I dont have to, i dont want to! Good luck on yours, and I will pay attention to this thread. I will post in it if I find out anything for you as well.
 




cusingeorge

Member
Joined
December 23, 2008
Messages
12
Reaction score
0
City, State
Calumet, Oklahoma
Year, Model & Trim Level
97 Sport and 07 Limited
Jeeze, Springfield, MO huh?

I'm in Nixa!

:D:D:D:D:D:D
 




corkey

Moderator Emeritus
Moderator Emeritus
Joined
January 3, 2008
Messages
6,007
Reaction score
48
Location
Sioux Narrows Canada
City, State
Elite Canuck,multiple ifs offender,, and musky maniac,, i wheel and i fish,,
Year, Model & Trim Level
99 xls,96 xl,91,08 Ranger
have somebody turn on the key while you listen to the gas tank for the fuel pump,, does it labour,, or run at a high pitch,, ?? if it seems like it is labouring,it could be going bad,
i recently have worked on a few vehicles that had bad pumps, one would run, but not good,, after the pump it ran fine,,
 








cusingeorge

Member
Joined
December 23, 2008
Messages
12
Reaction score
0
City, State
Calumet, Oklahoma
Year, Model & Trim Level
97 Sport and 07 Limited
have somebody turn on the key while you listen to the gas tank for the fuel pump,, does it labour,, or run at a high pitch,, ?? if it seems like it is labouring,it could be going bad,
i recently have worked on a few vehicles that had bad pumps, one would run, but not good,, after the pump it ran fine,,


I can hear it, high pitch, runs for a few seconds (2-3) then stops. I am assuming this is because it has reached the proper pressure before start-up?
 




dogfriend

Human-Animal Hybrid
Joined
July 22, 2002
Messages
7,561
Reaction score
7
City, State
Carmichael, CA
Year, Model & Trim Level
'97 Sport 4x4




team

Well-Known Member
Joined
November 5, 2008
Messages
218
Reaction score
1
Year, Model & Trim Level
1996
It would be nice to see the fuel trims on both banks. I would also like to see which cylinders are missfiring the most. For a free try you could switch your bank 1 and 2 o2 sensors to see if the code follows to bank 2 (this would say you have a bad o2). You should try to get a fuel pressure tester and read your pressure. But you may end up having the leaky OHC intake o rings syndrone.
 




Cobraguy

Explorer Addict
Joined
February 22, 2008
Messages
2,520
Reaction score
16
City, State
Phoenix...Greatest City on Earth
Year, Model & Trim Level
1995 EB & 1999 EB 5.0
I can hear it, high pitch, runs for a few seconds (2-3) then stops. I am assuming this is because it has reached the proper pressure before start-up?

No...it's only designed to run appx two seconds then quit until cranking starts.
 




cusingeorge

Member
Joined
December 23, 2008
Messages
12
Reaction score
0
City, State
Calumet, Oklahoma
Year, Model & Trim Level
97 Sport and 07 Limited
It would be nice to see the fuel trims on both banks. I would also like to see which cylinders are missfiring the most. For a free try you could switch your bank 1 and 2 o2 sensors to see if the code follows to bank 2 (this would say you have a bad o2). You should try to get a fuel pressure tester and read your pressure. But you may end up having the leaky OHC intake o rings syndrone.

It has not misfired since that one day, the CEL has not come back on, and it runs without missing a beat. It does seem to have a rough idle.

Tell me more about the leaky OHC intake o rings syndrome.....
 




Top