Tune up time!! What's best | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

Tune up time!! What's best

Dave422

Member
Joined
April 18, 2011
Messages
18
Reaction score
0
City, State
OK
Year, Model & Trim Level
95 EB
Hey peeps, I've recently purchased a '95 Eddie Bauer with a low low 240000 miles on it. I'm wanting to do some plugs and wires and am not sure if I should go with stock motorcrafts, or something more expensive. This is the first I've ever worked with the coil packs. I'd like to get better power and or mileage if possible, as I spend alot of time on the highway. Also, how can I tell if the overdrive is on or off, the light on the button doesn't work and the thing wraps up around 3 grand at 65 mph. Is that normal? Any help would be great! Thanks!!
 
<

Join the Elite Explorers $20 Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




sport97

Elite Procrastinator
Joined
September 25, 2008
Messages
2,348
Reaction score
1
City, State
connellsville pa
Year, Model & Trim Level
1997 sport SOHC 4.0
The consensus here is only motorcraft for plugs and wires.
 
<



dcdyd

Well-Known Member
Joined
January 7, 2011
Messages
371
Reaction score
0
City, State
Eden Prairie, MN
Year, Model & Trim Level
98 Explorer
You call 240K miles with 95 EB 'low low miles'? Then how about mine 98 EB with 106K?

My plugs were replaced by a shop and I did the wire. I used Autolite professional wire. I think that I get 1-2 miles/gallon efficiency after replacing the wire.
 
<



Dave422

Member
Joined
April 18, 2011
Messages
18
Reaction score
0
City, State
OK
Year, Model & Trim Level
95 EB
Yeah, the low miles was sarcasm! I think I'll stick with motorcraft. Ford stuff for the ford. Thanks for the advice. Do you know anything about my overdrive problem?
 
<



sport97

Elite Procrastinator
Joined
September 25, 2008
Messages
2,348
Reaction score
1
City, State
connellsville pa
Year, Model & Trim Level
1997 sport SOHC 4.0
The OD should be on by default, meaning the light is not lit on the dash. The light would be lit if you clicked the button to disengage. As for the 3k at 65, seems high. What motor, and what gears do you have? There is a code for the gear ratio on the door jamb sticker.
 
<



dcdyd

Well-Known Member
Joined
January 7, 2011
Messages
371
Reaction score
0
City, State
Eden Prairie, MN
Year, Model & Trim Level
98 Explorer
May be clean MFA, do seaform could get RPM down a little? At highway, my 98EB normally runs at 2000 to 2500RPM.
 
<



Dave422

Member
Joined
April 18, 2011
Messages
18
Reaction score
0
City, State
OK
Year, Model & Trim Level
95 EB
I did seafoam, through brake booster vacuum. What is MFA and how do I clean it?
 
<



Dave422

Member
Joined
April 18, 2011
Messages
18
Reaction score
0
City, State
OK
Year, Model & Trim Level
95 EB
It's the 4.0 OHV. I think 3:73 4wd. I will go out and check ratio ic I need too if that doesn't sound right.
 
<



sport97

Elite Procrastinator
Joined
September 25, 2008
Messages
2,348
Reaction score
1
City, State
connellsville pa
Year, Model & Trim Level
1997 sport SOHC 4.0
I have the SOHC 4.0, so it could differ, but even with 4.10s i don't hit 3k until about 75mph. To see if your O/D works, since you said the light does not function, try and count the shifts to see if it does indeed shift into o/d.
 
<



Dave422

Member
Joined
April 18, 2011
Messages
18
Reaction score
0
City, State
OK
Year, Model & Trim Level
95 EB
The code for axle is 46, which according to a different posting on here, it is the 3:73. I hate to sound stupid, but when I count the shifts how many should there be. If it helps, it does kick down when I go to pass. I accidentally hit the button a couple of times while not thinking about it ( not sure why) so I tried hitting it while driving a few times and never noticed any change on tach. Should I?
 
<



Joe Dirt

Explorer Addict
Joined
October 4, 2007
Messages
13,365
Reaction score
21
Year, Model & Trim Level
07 Camry
If you're on the highway and hit the OD off button, it should downshift. If it isn't, you don't have overdrive engaging, which explains the high RPM.

The MFA is supposed to be MAF, or mass airflow sensor- get some dedicated mass airflow sensor to clean it, if it hasn't been done at 200k+ it should probably be cleaned.

CLICK ME


Good choice on the Motorcraft parts, too. :thumbsup:
 
<



Dave422

Member
Joined
April 18, 2011
Messages
18
Reaction score
0
City, State
OK
Year, Model & Trim Level
95 EB
Ahh. That makes sense foe MAF. How does OD work? Can I check to see if it's engaging?
 
<



jlsparky7

Explorer Addict
Joined
April 4, 2009
Messages
1,504
Reaction score
3
City, State
Woodhaven, Mi
Year, Model & Trim Level
1996 5.0 XLT AWD
Check out the link in my signature. Tons of ideas there. check out www.rockauto.com for some excellent deals.
 
<



Joe Dirt

Explorer Addict
Joined
October 4, 2007
Messages
13,365
Reaction score
21
Year, Model & Trim Level
07 Camry
OD is just another "gear"

If you're running at 70 on the highway, hit the OD off button on the end of your gearshifter, and nothing happens (i.e. no downshift) your OD isn't working.
 
<



Dave422

Member
Joined
April 18, 2011
Messages
18
Reaction score
0
City, State
OK
Year, Model & Trim Level
95 EB
So how do I diagnose the problem? I searched the forum, butthere is so much info, I'm having a hard time finding help for my problem. Thank you.
 
<



Dave422

Member
Joined
April 18, 2011
Messages
18
Reaction score
0
City, State
OK
Year, Model & Trim Level
95 EB
Ok, I checked voltage at the fuse (26), and continuity across the fuse. All good there. I then pulled the button out of the shift lever and checked voltage at the terminals. That was good too. Then I checked con. of button with the switch closed and it was good. I pulled the truck on ramps and got under it. There appears to be two harnesses plugged into tranny, both look ok, but its very dirty down there. It looks like I may need a rear main seal. I have checked fluid, it's good.
 
<



shadowfigure

New Member
Joined
April 19, 2011
Messages
5
Reaction score
0
City, State
Great AK
Year, Model & Trim Level
2000 XLS
I know that in my '00 the overdrive is automatically reset every time the truck is turned off. So if i had turned the overdrive off before shutting the truck down, then it will be on when i start back up. Or so said my owners manual.
 
<



dcdyd

Well-Known Member
Joined
January 7, 2011
Messages
371
Reaction score
0
City, State
Eden Prairie, MN
Year, Model & Trim Level
98 Explorer
I know that in my '00 the overdrive is automatically reset every time the truck is turned off. So if i had turned the overdrive off before shutting the truck down, then it will be on when i start back up. Or so said my owners manual.

This is really odd. I thought OD is always on unless you intentionly turn it off.
 
<



SoNic67

Explorer Addict
Joined
January 24, 2010
Messages
3,051
Reaction score
15
City, State
Newport News, VA
Year, Model & Trim Level
2001 V8 (Eddie Bauer) AWD
OD is always engaged. Uless you turn it off manually.
BUT - the OD not working can signal a transmission problem, not just the button...
At 70mph I am at around 2200 rpm in OD. Over 3000rpm is the third gear.
The button itself pops out easily and you can check the contact. Check the fluid level too.

As for tune-up: Use Autolite XP plugs (I think is XP104 for yours). Forget about those overated Motorcraft (btw - made by Autolite too).
 
<

Join the Elite Explorers $20 Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




bobflood

Elite Explorer
Joined
May 27, 2010
Messages
1,578
Reaction score
31
City, State
Powder Springs, GA
Year, Model & Trim Level
1997 Eddie Bauer V8 2WD
So how do I diagnose the problem? I searched the forum, butthere is so much info, I'm having a hard time finding help for my problem. Thank you.

Dave422 - To check if OD is working:
- Take truck out on highway up to 60MPH or so; truck should be in OD.
- Push button to turn OD off; light should come on.
- If OD is working correctly, transmission will shift down. You will see RPMs increase about 500 RPM.
- If OD NOT working correctly, RPMs will NOT change.

At 3000 RPMs at 65 MPH, it is likely that your OD is not engaging. Further analysis required to figure out why.
 
<



Top