• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^

Tuning my 347 with rear mount turbo


Dono

347 V8 Limited turbo
Elite Explorer
Joined
February 18, 2009
Messages
5,270
Reaction score
539
City, State
Winnipeg, Manitoba
Year, Model & Trim Level
00 Limited V8
I felt I'd start a thread to document for myself and possibly help someone else down the road.

After struggling with numerous issues with my 347 (interestingly enough, the rear mount turbo's performance has been flawless), James Henson leaving the business, and some other guys here tuning with SCT with great success I decided to dive in.

I purchased all training material and a base tune from Lasota Racing. They have been an excellent company to deal with.

The base tune was my strategy REAC with other areas such as maf transfer and border knock table (Only high load, high rpm) completed on a dyno.

I did have lots of help from a member here with step testing to dial in the low end of maf transfer. I have not completed wot testing yet, so I have concentrated on the drive-ability without going wot.

I had a look at Decipha's information, and learned where my MBT spark should be on the configuration I have. http://www.efidynotuning.com/mbt.htm
With my TW FAC heads, higher compression, and bigger bore, I guessed that a safe sweet spot would be a degree lower than the chart shows.
MBT @ 2k CRUISE 14 IN/HG = 45
MBT @ 3k+ 0 VAC / 0 BOOST = 35

I then set my maximum spark table a couple of degree's under this as a measure of safety. I'll post my work in progress on the borderline spark table as that's the table where I plan on controlling spark most of the time. So far, no detonation detected.

I'm a little late on the spark advances as I don't want to be replacing my head gaskets again. Tweak, upload, run for a day or two and repeat. So far, I'm only advancing the drive around low load part of the table. Decipha's chart seems to be right on. Thank you [MENTION=163567]decipha[/MENTION] Greatly appreciated.

I will say that as I'm advancing timing, my rear mount turbo is starting to sing. It would seem that rear mount turbo's are not happy with retarded timing. Interesting, and its going to add more difficulty as I get closer to that line in advancing without stepping over it.

I have also been spending lots of time on shift and torque converter curves. This is a huge reason to do your own tuning in its self. The results are amazing for drive-ability, and there is no way you could expect someone else to put the time in to this that's required. Using the factory tuning, the torque converter wouldn't lock up till 80mph. That's crazy for a high torque 347. More than enough power at 2000 rpm and 60mph to support lockup.

Lets see....Another issue has been hard starting when the motor is warm. I think the cam has something to do with this. This seems to be kind of a trial and error thing. Hard to expect a remote tuner to get this done without a lot of frustration on both sides.

Since I have started self tuning my wife can't believe how great the truck is running. Every time she gets in it she comments that it just keeps sounding and feeling better.

As the days are getting longer and the weather warms up I'll start learning the wot tuning part. I just haven't had the energy to go out in the dark to do wot pulls. Traction and safety is a concern also.

I'll start updating this thread with pictures showing where I'm at with various tables.
 
Last edited:


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




delexploder

Well-Known Member
Joined
March 11, 2012
Messages
1,991
Reaction score
105
City, State
Greenwood De.
Year, Model & Trim Level
97 ford explorer sport
Very good to here you are making progress.
 




Dono

347 V8 Limited turbo
Elite Explorer
Joined
February 18, 2009
Messages
5,270
Reaction score
539
City, State
Winnipeg, Manitoba
Year, Model & Trim Level
00 Limited V8
A few graphs

I took a few minutes to show where I am at with the converter and spark.
If you notice, the spark is very conservative up top as I don't have the maf dialed in for the a/f ratio yet. As with my first post, you can see how I have been more aggressive at low loads. Apparently its true that aluminum heads need more timing.

Also, if you notice the factory converter lockup schedule you will see that it never really locks up in 4th based on throttle position at reasonable speeds on the hwy (The throttle was pressed to much for the converter to actually lock until high speeds). I'm pretty close to what 'feels' good on the converter now. A few more tweaks, and thats about it.

On a side note, my coolant level is stable. As long as I can keep from pushing combustion gasses in to the coolant its all good.
 

Attachments





2000StreetRod

Staff member
Moderator
Elite Explorer
Joined
May 26, 2009
Messages
10,590
Reaction score
231
City, State
Greenville, SC
Year, Model & Trim Level
00 Sport FI, 03 Ltd V8
what load?

. . . With my TW FAC heads, higher compression, and bigger bore, I guessed that a safe sweet spot would be a degree lower than the chart shows.
MBT @ 2k CRUISE 14 IN/HG = 45
MBT @ 3k+ 0 VAC / 0 BOOST = 35
. . .
What are the loads for the above? With your turbo what are the driving conditions to achieve 3k rpm @ 0 VAC / 0 BOOST?
 




Dono

347 V8 Limited turbo
Elite Explorer
Joined
February 18, 2009
Messages
5,270
Reaction score
539
City, State
Winnipeg, Manitoba
Year, Model & Trim Level
00 Limited V8
What are the loads for the above? With your turbo what are the driving conditions to achieve 3k rpm @ 0 VAC / 0 BOOST?
The answer is, I don't know.
First, I need to datalog boost. We discussed that way back in time, and for some reason my equation quit working. Its hard to datalog and remember when you hit that spot. Also, the shift points have a bearing on this.

I have stayed conservative on this with my driving around. Honestly, I have not even hit 3k with 0 vac/boost yet. I need to start datalogging (and get that equation working for analog 1) so I know where I'm at to be sure. The changes I made moving the spark up from the base tune was at low load conditions. This was actually backed right off. My mileage has already gone way up.

My rear mount turbo does not make boost anywhere near as fast as your M90, so that's why you are seeing that advanced timing where you would be cringing.
 




2000StreetRod

Staff member
Moderator
Elite Explorer
Joined
May 26, 2009
Messages
10,590
Reaction score
231
City, State
Greenville, SC
Year, Model & Trim Level
00 Sport FI, 03 Ltd V8
What MAF sensor?

I can't remember your configuration. If you changed your MAF sensor are you using an MTF for the new MAF sensor?
Have you changed the engine displacement in the tune to match your current displacement?
I suggest that you log your load if you're not already doing so. Altering the MTF and the engine displacement can significantly change the calculated load which will change what spark advance the PCM pulls from the BKT. If your calculated load is significantly less than you anticipate the spark will be more advanced. As you alter the MTF to achieve the desired AFR your load will also change.
 




Dono

347 V8 Limited turbo
Elite Explorer
Joined
February 18, 2009
Messages
5,270
Reaction score
539
City, State
Winnipeg, Manitoba
Year, Model & Trim Level
00 Limited V8
As a side note, here is where 2000Streetrod helped me with the AEM boost equation for logging boost.
http://www.explorerforum.com/forums/showthread.php?t=415344
Here is the equation used: (12.5*v)-20.95 Its correct for boost, but not for vac.

On my to do list is to prep the latest tune for a wot pull.
adaptive control switch 0
Trans converter Unlock 3rd 20mph
Trans Shift Schedule 21 8mph
Trans shift schedule 32 20mph

I created a small file that I can append to a tune quickly. It seems I still have to select the values to append to before it works though. Not as fast as I'd like.
 




Dono

347 V8 Limited turbo
Elite Explorer
Joined
February 18, 2009
Messages
5,270
Reaction score
539
City, State
Winnipeg, Manitoba
Year, Model & Trim Level
00 Limited V8
I can't remember your configuration. If you changed your MAF sensor are you using an MTF for the new MAF sensor?
Have you changed the engine displacement in the tune to match your current displacement?
I'm using a slot maf. I was told previously to use the BA5000 as a base. This is exactly what came with the base tune, and was pretty close. I also checked the displacement, and it was set correctly for my 347.
I have done step testing/logging and have the the maf transfer set up within a nice tight tolerance up to 4000rpm. I expect the maf transfer to change slightly at about 3000rpm and up under load.

I am already logging load. I adjusted my analog1 and hope the equation works better for me (I had some other equation there in error) Tomorrow I'll try to do a wot pull. I'm fully expecting to not go over about 4500rpm on the first pull. Adjust Maf transfer, and try again. I'm sure there will be some redo, and redo again as the maf transfer a/f ratio gets dialed in.
 




4pointslow

Explorer Torture Tester
Elite Explorer
Joined
April 3, 2008
Messages
2,930
Reaction score
421
City, State
Gloucester City, NJ
Year, Model & Trim Level
98 2Dr,98 & 04 4dr xlt
Value Files

I created a small file that I can append to a tune quickly. It seems I still have to select the values to append to before it works though. Not as fast as I'd like.
If you are creating value files you shouldn't have to select the values to append each time, have you tried it again to see if it still makes you?
 




Dono

347 V8 Limited turbo
Elite Explorer
Joined
February 18, 2009
Messages
5,270
Reaction score
539
City, State
Winnipeg, Manitoba
Year, Model & Trim Level
00 Limited V8
The devil seems to be in learning the software.

I tried again, actually comprehending what I was reading and was able to load the wot testing file without selecting the areas I wanted to change.

I guess thats where 'load all values', as opposed to 'load selected values' comes in to play. :banghead:

This will save time.
 




vroomzoomboom

Elite Canuck STOCK SUCKS!
Elite Explorer
Joined
January 22, 2007
Messages
9,435
Reaction score
724
City, State
selkirk, manitoba
Year, Model & Trim Level
98 supercharged 347 sport
wow....looking at what you posted....i am not looking forward to this when mine comes in, but who knows. you can teach a old dog new tricks. i am used to tuning with a screw driver, timing light and vacuum gauge
 




Dono

347 V8 Limited turbo
Elite Explorer
Joined
February 18, 2009
Messages
5,270
Reaction score
539
City, State
Winnipeg, Manitoba
Year, Model & Trim Level
00 Limited V8
I love this place!

I didn't quite understand what 2000Streetrod was getting at with the load issue. I needed to 'Normalize' my spark so that it would account for loads greater than .899 and allow for higher rpm.
This involves adjusting the X and Y axis. Here are the results: Notice I now have load up to 1.4 and rpm to 6200?

To all involved. Thank you. Its stuff like this that a new-be can easily miss. I purchased a base tune, and its exactly that. A great start.

Tomorrow I'll check fuel tables for normalizing and lower some of my borderline spark numbers. I'm so done. It's bed time.
 

Attachments





2000StreetRod

Staff member
Moderator
Elite Explorer
Joined
May 26, 2009
Messages
10,590
Reaction score
231
City, State
Greenville, SC
Year, Model & Trim Level
00 Sport FI, 03 Ltd V8
Scale limits

For table controlled parameters the PCM determines the parameter value by comparing the measured values of the indices to those defined in the associated table. For some parameters such as Spark Retard for ACT the PCM just uses the value in the table for the appropriate row and column.
SparkRetardACT.jpg

In the table above if the ACT is equal to or greater than 126 but less than 150 the Spark Retard for ACT will be -16 for all engine speeds. This is multiplied by the Spark Retard ACT Multiplier to get the total ACT related spark retard. I have all of my entries set to 0.1 in the table to simplify the calculation.
SparkRetardACTMult.jpg

So for the above if my ACT is 149 degrees F. the overall ACT spark retard will be -1.6 degrees and for ACT = 150 degrees F. the overall ACT spark retard will be -3.2 degrees. That's why I'm trying to get my ACT (IAT) below 150 degrees F.

On other tables such as Borderline Knock and lambda the PCM interpolates to determine a more exact value. Below is my Borderline Knock Table.
BKT6FISOHC.jpg

If the load is 0.6 and the rpm is 4500 the PCM assumes a linear change between 4000 and 5000 and uses the value of 22.5. If the load is 0.8 and the rpm is 2000 the PCM assumes a linear change and uses the value of 16.0. The PCM performs double interpolation (x and y axes) to get the best value. I have found thru testing that the PCM does not extrapolate accurately. Extrapolation is using the slope of two defined points in the table to predict a value for index values outside of the table. For that reason I have set my normalizers to make sure the actual engine parameters will never exceed the limits defined in the tables. I set my table limits only slightly greater than what I think is possible (or planned) to prevent losing accuracy. That is why my table rpm goes to 6500 even though my speed limiter is set to 6250.
 




2000StreetRod

Staff member
Moderator
Elite Explorer
Joined
May 26, 2009
Messages
10,590
Reaction score
231
City, State
Greenville, SC
Year, Model & Trim Level
00 Sport FI, 03 Ltd V8
torque converter lock/unlock

Below is the my 2000 stock torque converter lock/unlock schedule for 4th and 5th speeds.
ConverterLock.jpg

The lock and unlock difference at high TPS is greater for 5th than 4th and continues the trend for 3rd and 2nd speeds. In my opinion the schedule would be much more useful if the table was indexed by engine speed instead of vehicle speed. Then the relationship converter lock/unlock to engine torque would be more obvious.
 




Dono

347 V8 Limited turbo
Elite Explorer
Joined
February 18, 2009
Messages
5,270
Reaction score
539
City, State
Winnipeg, Manitoba
Year, Model & Trim Level
00 Limited V8
Yesterday was a bit, um, frustrating.
I'm going to call it a learning day.
It's a good thing I had the boost controller set low (2 lbs boost).

What I learned was my load levels are low. At 2 lbs boost, I hit a load level of .84.
You can only imagine with my spark tables set the way they were how much spark advance was being thrown at the motor. Not good. Lets just say that I have not looked at the coolant reservoir yet. Between my load levels being lower than I thought and the wot spark adder table I missed and didn't set to '0' the result was possibly very damaging.

So, I ended up pulling all kinds of timing for setting a/f ratio. After I have that nailed, I'll slowly advance timing.
My next issue is my wideband. Its reading rich. I'm hoping this is an easy fix with a calibration. Secondly, it bounces around, making it even more difficult to see exactly what your adjusting since I can have 2 completely different a/f readings at the same air flow. I'm going to try to get the main unit in a cooler location. This is difficult as the sensor cable isn't exactly long. Without the wideband working properly, wot tuning is impossible.
 

Attachments





2000StreetRod

Staff member
Moderator
Elite Explorer
Joined
May 26, 2009
Messages
10,590
Reaction score
231
City, State
Greenville, SC
Year, Model & Trim Level
00 Sport FI, 03 Ltd V8
wot spark adder table ?

. . . Between my load levels being lower than I thought and the wot spark adder table I missed and didn't set to '0' the result was possibly very damaging. . .
I'm not familiar with that table. The closest thing to that I have in my strategy is the Spark Adder for A/F when Open Loop table.
SparkAdderOpenLoop.jpg
 




Dono

347 V8 Limited turbo
Elite Explorer
Joined
February 18, 2009
Messages
5,270
Reaction score
539
City, State
Winnipeg, Manitoba
Year, Model & Trim Level
00 Limited V8




2000StreetRod

Staff member
Moderator
Elite Explorer
Joined
May 26, 2009
Messages
10,590
Reaction score
231
City, State
Greenville, SC
Year, Model & Trim Level
00 Sport FI, 03 Ltd V8
Unstable AFR

. . . Secondly, it bounces around, making it even more difficult to see exactly what your adjusting since I can have 2 completely different a/f readings at the same air flow. I'm going to try to get the main unit in a cooler location. This is difficult as the sensor cable isn't exactly long. Without the wideband working properly, wot tuning is impossible.
Does the value on the display "bounce around" or is it just the datalogged value? On my 2003 virtually none of the pids datalog reliably. Some of my battery voltage readings are in the trillions. I have some electrical troubleshooting and wiring to perform before I can do any tuning.
 




Dono

347 V8 Limited turbo
Elite Explorer
Joined
February 18, 2009
Messages
5,270
Reaction score
539
City, State
Winnipeg, Manitoba
Year, Model & Trim Level
00 Limited V8
Notice the analog2
Very odd, and not very helpful.
 

Attachments



Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




Dono

347 V8 Limited turbo
Elite Explorer
Joined
February 18, 2009
Messages
5,270
Reaction score
539
City, State
Winnipeg, Manitoba
Year, Model & Trim Level
00 Limited V8
Here's a pic of my wideband.
I re-calibrated it. At least it started reading closer, but still bouncing all over the place.
I then slowed its response time to 1/6 of a second instead of instant. This is what I have now.
The motor is was cool, so heat isn't the issue. The sensor is new (The other one wouldn't heat). I think its broke (Either the new sensor is bad, or the control unit is done). Either way.... :(
 

Attachments





Top