very high idle in park | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! Once registered you can join the Elite Explorers to eliminate ads from the website.

very high idle in park

tgreene92

Well-Known Member
Joined
July 28, 2009
Messages
407
Reaction score
0
City, State
south jersey
Year, Model & Trim Level
'98 XLT x2
here is my issue, every time i start my x it immediately idles at a little less than 2500 rpm's, if it sits for a minute it'll bog down slightly for less than a second only to jump up to 3500 rpm's. it'll idle like this even if the car is warmed up. when i go into reverse or drive it'll slam down hard to about 1000 to 1500 rpm's. the only code it threw was for the 2-3 shift flare issue. its a 98 xlt 4.0 sohc, new idle air control which i recently cleaned, recently cleaned MAF, air filter, and all under the hood electric connections, i did all this in hopes of fixing the problem with no success. this is leading me to think it is more of a tranny issue than air or fuel problem even tho i have not troubleshot any fuel issues. the tranny does shift late often and downshift hard even tho it is less than a year old. any quick help would be greatly appreciated, i have no other car and id like to fix this before it dies on me.
 












tgreene92

Well-Known Member
Joined
July 28, 2009
Messages
407
Reaction score
0
City, State
south jersey
Year, Model & Trim Level
'98 XLT x2
yea ive had a whistling too which i suspected to be a vacuum leak i didnt know the two could be connecting problems however, thx for the info ill check and hopefully fix tomorrow.
 






Top